Bug 212323 - Tuning fails on DViCO FusionHDTV DVB-T Plus
Tuning fails on DViCO FusionHDTV DVB-T Plus
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 05:54 EDT by Michael Chapman
Modified: 2007-12-31 02:21 EST (History)
3 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 02:21:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Chapman 2006-10-26 05:54:18 EDT
Description of problem:

My DViCO FusionHDTV DVB-T Plus card can no longer tune in TV stations. This
problem appears to be kernel-related, as it's affecting any software that uses
it, eg. MythTV, mplayer, xine, etc.

Version-Release number of selected component (if applicable):

kernel-2.6.18-1.2798.fc6

I think the bug was introduced some time between kernel-smp-2.6.17-1.2187_FC5
and kernel-smp-2.6.18-1.2200.fc5, as I had the same problem when upgrading the
kernel on my FC5 installation. Downgrading back to 2.6.17-1.2187_FC5 had
rectified the problem.

How reproducible: Always

Steps to Reproduce:
1. Run 'tzap -c <conffile> <channel>' (in the dvb-apps package)

Actual results:

$ tzap -c channels.conf 'ABC2'
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
tuning to 226500000 Hz
video pid 0x0903, audio pid 0x0904
status 00 | signal b11f | snr 0000 | ber 00000000 | unc 00000000 | 
status 00 | signal dfef | snr 0000 | ber 00000000 | unc 00000000 | 
status 00 | signal cf9f | snr 0000 | ber 00000000 | unc 00000000 | 
status 00 | signal d03f | snr 0000 | ber 00000000 | unc 00000000 | 
status 00 | signal d0ff | snr 0000 | ber 00000000 | unc 00000000 | 
status 00 | signal d0af | snr 0000 | ber 00000000 | unc 00000000 | 
[...etc...]

Expected results:

"snr" should be non-zero. "FE_HAS_LOCK" should appear when the tuner locks onto
the signal.

Additional info:

/var/log/messages:

Oct 25 22:34:05 beren kernel: ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 20
(level, low) -> IRQ 233
Oct 25 22:34:05 beren kernel: CORE cx88[0]: subsystem: 18ac:db10, board: DViCO
FusionHDTV DVB-T Plus [card=21,autodetected]
Oct 25 22:34:05 beren kernel: TV tuner 4 at 0x1fe, Radio tuner -1 at 0x1fe
Oct 25 22:34:06 beren kernel: cx88[0]/0: found at 0000:02:00.0, rev: 5, irq:
233, latency: 32, mmio: 0xf0000000
Oct 25 22:34:06 beren kernel: cx88[0]/0: registered device video0 [v4l2]
Oct 25 22:34:06 beren kernel: cx88[0]/0: registered device vbi0
Oct 25 22:34:06 beren kernel: cx2388x dvb driver version 0.0.6 loaded
Oct 25 22:34:06 beren kernel: ACPI: PCI Interrupt 0000:02:00.2[A] -> GSI 20
(level, low) -> IRQ 233
Oct 25 22:34:06 beren kernel: cx88[0]/2: found at 0000:02:00.2, rev: 5, irq:
233, latency: 32, mmio: 0xf1000000
Oct 25 22:34:06 beren kernel: cx88[0]/2: cx2388x based dvb card
Oct 25 22:34:06 beren kernel: DVB: registering new adapter (cx88[0]).
Oct 25 22:34:06 beren kernel: DVB: registering frontend 0 (Zarlink MT352 DVB-T)...
Oct 25 22:34:06 beren kernel: ACPI: PCI Interrupt 0000:02:01.0[A] -> GSI 19
(level, low) -> IRQ 217
Oct 25 22:34:06 beren kernel: Model 1001 Rev 00000000 Serial 10011102
Oct 25 22:34:06 beren kernel: cx2388x blackbird driver version 0.0.6 loaded

`/sbin/lspci`:

02:00.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio
Decoder (rev 05)
02:00.2 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio
Decoder [MPEG Port] (rev 05)
Comment 1 Tim Mayberry 2006-10-31 19:29:18 EST
I have the same hardware and although I haven't been using it recently I plugged
it in last night and tried tuning it to reproduce this bug. I can confirm that
tuning works in the original FC5 kernel(2.6.15) but not after I updated to
version 2.6.18-1.2200.fc5. I tried using FC6 but was also unsuccessful.

It looks like there have been a lot of changes in the driver for that card
between 2.6.17 and 2.6.18 and I found a post in the linux-dvb mailing list
archive that looks very relevant:

http://www.linuxtv.org/pipermail/linux-dvb/2006-September/012639.html
Comment 2 Michael Chapman 2006-11-04 23:38:08 EST
Thanks for the link. I installed the latest v4l modules and it has fixed the
problem.

$ tzap -c channels.conf 'ABC2'
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
tuning to 226500000 Hz
video pid 0x0903, audio pid 0x0904
status 00 | signal c9cf | snr 0000 | ber 00000000 | unc 00000006 | 
status 1f | signal c9af | snr efef | ber 00000000 | unc 00000000 | FE_HAS_LOCK
status 1f | signal c9ff | snr efef | ber 00000000 | unc 00000000 | FE_HAS_LOCK
status 1f | signal c8cf | snr efef | ber 00000000 | unc 00000000 | FE_HAS_LOCK
Comment 3 Jon Stanley 2007-12-30 22:31:07 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 4 Michael Chapman 2007-12-31 02:21:02 EST
This was fixed sometime during FC6.

Note You need to log in before you can comment on or make changes to this bug.