Bug 212331 - SVN in monodevelop is not working.
SVN in monodevelop is not working.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 07:37 EDT by Mikkel Kruse Johnsen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.12-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-24 11:21:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mikkel Kruse Johnsen 2006-10-26 07:37:52 EDT
Description of problem:

Monodevelop's SVN is compiled to use "libapr-0.so.0", but the package
"apr-1.2.7-10" includes "libapr-1.so.0". So it fails.

Version-Release number of selected component (if applicable):
FC6
monodevelop-0.12-5.fc6
apr-1.2.7-10

How reproducible:
Try to use the "log" feature under Version Control.

Steps to Reproduce:
1. Click on a file in the product
2. Select Version Control
3. Select Log
  
Actual results:

The operation could not be completed because a shared library is missing:
libapr-0.so.0

Expected results:

The log for the file.

Additional info:
Comment 1 Paul F. Johnson 2006-10-27 18:05:44 EDT
I can't see this error on x86_64 or on my laptop (x86). Is monodevelop falling
over dead when you try to use the log?
Comment 2 Mikkel Kruse Johnsen 2006-10-28 05:01:52 EDT
No it just report "The operation could not be completed because a shared library
is missing: libapr-0.so.0" in the Version Control windows (just below the main
edit window).

Just updated to "monodevelop-0.12-6.fc6" the error is still there.

Comment 3 Paul F. Johnson 2006-10-30 09:13:18 EST
have you got apr-devel installed on your machine?
Comment 4 Eskil Bylund 2006-12-14 22:48:59 EST
I can confirm this. Monodevelop is looking for libapr-0.so.0, but the library
provided by apr is libapr-1.so.0. Support for libapr-1 seems to be in
Monodevelop SVN.

Monodevelop will crash when running under Mono 1.2 because of this, so the
version control addin should probably be disabled in Rawhide (and FC6 too since
it's broken?).
Comment 5 Paul F. Johnson 2006-12-20 17:17:00 EST
I'll disable it

Note You need to log in before you can comment on or make changes to this bug.