Bug 212390 - Evolution crash on closedown
Evolution crash on closedown
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
i686 Linux
high Severity high
: ---
: ---
Assigned To: Milan Crha
:
Depends On:
Blocks: 219362
  Show dependency treegraph
 
Reported: 2006-10-26 12:38 EDT by Motor
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: evolution-2.10.3-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-17 12:08:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evolution-backtrace.txt (7.50 KB, text/plain)
2006-11-05 09:34 EST, Kevin Verma
no flags Details
evolution-stderr.txt (3.24 KB, text/plain)
2006-11-05 15:20 EST, Kevin Verma
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 334966 None None None Never

  None (edit)
Description Motor 2006-10-26 12:38:37 EDT
Description of problem:
Closing down evolution causes the GNOME crash dialog to appear, roughly every
other time. The bugreporting tools does collects information, saying it is the
Calendar component that has crashed. The bugreporting tool does not allow
automated submission of the bug, so I have included the backtrace information here.

The system on whcih it is running was previously an FC5 installation, which
demonstrated the same crash behaviour. It has now been updated to FC6 and still
crashes.

Version-Release number of selected component (if applicable):
evolution-2.8.0-7.fc6

Additional info:
Distribution: Fedora Core release 6 (Zod)
Gnome Release: 2.16.0 2006-09-04 (Red Hat, Inc)
BugBuddy Version: 2.16.0

Memory status: size: 168681472 vsize: 0 resident: 168681472 share: 0 rss:
33312768 rss_rlim: 0
CPU usage: start_time: 1161879631 rtime: 0 utime: 529 stime: 0 cutime:457
cstime: 0 timeout: 72 it_real_value: 0 frequency: 0

Backtrace was generated from '/usr/bin/evolution'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208203040 (LWP 3792)]
[New Thread -1311728752 (LWP 3809)]
[New Thread -1301242992 (LWP 3802)]
[New Thread -1290757232 (LWP 3801)]
[New Thread -1250124912 (LWP 3797)]
0x00d258f1 in __waitpid_nocancel () from /lib/libpthread.so.0
#0  0x00d258f1 in __waitpid_nocancel () from /lib/libpthread.so.0
#1  0x00962cf6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#2  0x0805d9c9 in segv_redirect (sig=11) at main.c:426
#3  <signal handler called>
#4  e_shell_window_set_title (window=0x961c850, component_id=0x98eb040 "mail", 
    title=0x9c1a7a0 "Mail - Evolution") at e-shell-window.c:1229
#5  0x0805b867 in impl_ShellView_setTitle (_servant=0x963c534, 
    id=0x98eb040 "mail", title=0xb7d4512e "Mail", ev=0xbf892b7c)
    at e-shell-view.c:48
#6  0x02309f9a in _ORBIT_skel_small_GNOME_Evolution_ShellView_setTitle (
    _o_servant=0x963c534, _o_retval=0x0, _o_args=0xbf892b4c, _o_ctx=0x0, 
    _o_ev=0xbf892b7c, _impl_setTitle=0x805b820 <impl_ShellView_setTitle>)
    at Evolution-common.c:24
#7  0x0013d7e0 in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#8  0x0230beaa in GNOME_Evolution_ShellView_setTitle (_obj=0x9642538, 
    component=0x98eb040 "mail", title=0xb7d4512e "Mail", ev=0xbf892b7c)
    at Evolution-stubs.c:27
#9  0x0230d51d in e_component_view_set_title (ecv=0x9860710, 
    title=0xb7d4512e "Mail") at e-component-view.c:136
#10 0x0107ee7e in view_changed_timeout (d=0x9860710) at mail-component.c:582
#11 0x0026f916 in g_source_get_current_time () from /lib/libglib-2.0.so.0
#12 0x0026f342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#13 0x0027231f in g_main_context_check () from /lib/libglib-2.0.so.0
#14 0x002726c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#15 0x008c9a23 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#16 0x0805d7fa in main (argc=1, argv=0xbf892f94) at main.c:615
#17 0x0034bf2c in __libc_start_main () from /lib/libc.so.6
#18 0x0804f221 in _start ()

Thread 5 (Thread -1250124912 (LWP 3797)):
#0  0x00d21f91 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#1  0x00252642 in g_async_queue_sort () from /lib/libglib-2.0.so.0
No symbol table info available.
#2  0x07f275ea in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.7
No symbol table info available.
#3  0x07f27c59 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
No symbol table info available.
#4  0x00d1e26a in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#5  0xb57c9470 in ?? ()
No symbol table info available.
#6  0xb57c9470 in ?? ()
No symbol table info available.
#7  0xb57c9470 in ?? ()
No symbol table info available.
#8  0xb57c9470 in ?? ()
No symbol table info available.
#9  0x00000000 in ?? ()
No symbol table info available.

Thread 4 (Thread -1290757232 (LWP 3801)):
#0  0x00d21f91 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#1  0x00252642 in g_async_queue_sort () from /lib/libglib-2.0.so.0
No symbol table info available.
#2  0x07f275ea in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.7
No symbol table info available.
#3  0x07f27c59 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
No symbol table info available.
#4  0x00d1e26a in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#5  0xb3109470 in ?? ()
No symbol table info available.
#6  0xb3109470 in ?? ()
No symbol table info available.
#7  0xb3109470 in ?? ()
No symbol table info available.
#8  0xb3109470 in ?? ()
No symbol table info available.
#9  0x00000000 in ?? ()
No symbol table info available.

Thread 3 (Thread -1301242992 (LWP 3802)):
#0  0x00d21f91 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#1  0x00252642 in g_async_queue_sort () from /lib/libglib-2.0.so.0
No symbol table info available.
#2  0x07f275ea in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.7
No symbol table info available.
#3  0x07f27c59 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
No symbol table info available.
#4  0x00d1e26a in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#5  0xb2709470 in ?? ()
No symbol table info available.
#6  0xb2709470 in ?? ()
No symbol table info available.
#7  0xb2709470 in ?? ()
No symbol table info available.
#8  0xb2709470 in ?? ()
No symbol table info available.
#9  0x00000000 in ?? ()
No symbol table info available.

Thread 2 (Thread -1311728752 (LWP 3809)):
#0  0x00d21f91 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#1  0x00252642 in g_async_queue_sort () from /lib/libglib-2.0.so.0
No symbol table info available.
#2  0x07f275ea in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.7
No symbol table info available.
#3  0x07f27c59 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
No symbol table info available.
#4  0x00d1e26a in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#5  0xb1d09470 in ?? ()
No symbol table info available.
#6  0xb1d09470 in ?? ()
No symbol table info available.
#7  0xb1d09470 in ?? ()
No symbol table info available.
#8  0xb1d09470 in ?? ()
No symbol table info available.
#9  0x00000000 in ?? ()
No symbol table info available.

Thread 1 (Thread -1208203040 (LWP 3792)):
#0  0x00d258f1 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#1  0x00962cf6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#2  0x0805d9c9 in segv_redirect (sig=11) at main.c:426
No locals.
#3  <signal handler called>
No symbol table info available.
#4  e_shell_window_set_title (window=0x961c850, component_id=0x98eb040 "mail", 
    title=0x9c1a7a0 "Mail - Evolution") at e-shell-window.c:1229
	priv = (EShellWindowPrivate *) 0xbf892a88
	p = <value optimized out>
#5  0x0805b867 in impl_ShellView_setTitle (_servant=0x963c534, 
    id=0x98eb040 "mail", title=0xb7d4512e "Mail", ev=0xbf892b7c)
    at e-shell-view.c:48
No locals.
#6  0x02309f9a in _ORBIT_skel_small_GNOME_Evolution_ShellView_setTitle (
    _o_servant=0x963c534, _o_retval=0x0, _o_args=0xbf892b4c, _o_ctx=0x0, 
    _o_ev=0xbf892b7c, _impl_setTitle=0x805b820 <impl_ShellView_setTitle>)
    at Evolution-common.c:24
No locals.
#7  0x0013d7e0 in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#8  0x0230beaa in GNOME_Evolution_ShellView_setTitle (_obj=0x9642538, 
    component=0x98eb040 "mail", title=0xb7d4512e "Mail", ev=0xbf892b7c)
    at Evolution-stubs.c:27
	_args = {0xbf892b64, 0xbf892b68}
#9  0x0230d51d in e_component_view_set_title (ecv=0x9860710, 
    title=0xb7d4512e "Mail") at e-component-view.c:136
	ev = {_id = 0x0, _major = 0, _any = {_type = 0x0, _value = 0x0, 
    _release = 0 '\0'}}
#10 0x0107ee7e in view_changed_timeout (d=0x9860710) at mail-component.c:582
	bits = <value optimized out>
	selected = <value optimized out>
	el = (EInfoLabel *) 0x95942c0
	emfv = (EMFolderView *) 0x9703800
#11 0x0026f916 in g_source_get_current_time () from /lib/libglib-2.0.so.0
No symbol table info available.
#12 0x0026f342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#13 0x0027231f in g_main_context_check () from /lib/libglib-2.0.so.0
No symbol table info available.
#14 0x002726c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#15 0x008c9a23 in bonobo_main () from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#16 0x0805d7fa in main (argc=1, argv=0xbf892f94) at main.c:615
	fd = <value optimized out>
	uri_list = (GSList *) 0x0
	program = (GnomeProgram *) 0x9579428
	context = <value optimized out>
	icon_list = <value optimized out>
#17 0x0034bf2c in __libc_start_main () from /lib/libc.so.6
No symbol table info available.
#18 0x0804f221 in _start ()
No symbol table info available.
#0  0x00d258f1 in __waitpid_nocancel () from /lib/libpthread.so.0
Comment 1 Kevin Verma 2006-10-31 01:18:13 EST
This issue is re-producing for me too, every time evolution is closed.
Comment 2 Matthew Barnes 2006-10-31 07:10:56 EST
Thanks for the bug report and traceback.

It sounds like you're seeing a bug that was reported upstream [1] and fixed in
Evolution 2.8.1, which is available in Fedora Testing Updates now.

Please write back and indicate whether the update fixes the crash on shutdown,
so that I know whether to investigate this further.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=334966
Comment 3 Kevin Verma 2006-11-01 09:53:37 EST
[kevin@localhost fc6-testing]$ rpm -qa |grep evolution |sort
beagle-evolution-0.2.10-3.fc6
evolution-2.8.1.1-3.fc6
evolution-data-server-1.8.1-1.fc6
evolution-sharp-0.11.1-10.fc6
evolution-webcal-2.7.1-6
[kevin@localhost fc6-testing]$

I have tested the Evo 2.8.1 but that fails and the crash still happens, what
exact more information will help you to have this traced and fixed ? 

Since this is effecting a major release of FC6, will you consider bumping up the
servity ? 
Comment 4 Kevin Verma 2006-11-01 09:55:11 EST
"Since this is effecting a major release of FC6, will you consider bumping up the
servity ?"

I mean user base of FC6 release :)
Comment 5 Motor 2006-11-01 10:27:36 EST
evolution-2.8.1.1-3.fc6
evolution-data-server-1.8.1-1.fc6
evolution-devel-2.8.1.1-3.fc6

I opened the bug and the backtrace show above is my machine. I installed the
testing RPMS as suggested, and the problem *seems* to have gone away -- at
least, I have not seen a crash since yesterday. Previously it was roughly every
other time.
Comment 6 Motor 2006-11-01 17:38:14 EST
Update: The crash behaviour has reoccurred... although it is now much less
frequent. So it seems the packages from testing have not solved the problem.
Comment 7 Kevin Verma 2006-11-02 07:02:08 EST
however the crash behaviour is re-producing everytime for me, hence the testing
RPMS does not help so far, any inputs from Barnes ? 
Comment 8 Matthew Barnes 2006-11-02 07:31:42 EST
Kevin, can you please attach a backtrace with debugging symbols?  I'd like to
compare it to the original problem report and make sure you're both hitting the
same bug.

Also, FYI, Evolution 2.9 (in Rawhide) seems pretty well-behaved at shutdown.
Comment 9 Motor 2006-11-04 05:34:25 EST
This bug seems to be trigged, at least on my system, by having Edit ->
Preferences -> Mail Preferences -> Empty Trash Folders On Exit (every time). It
also seems to be related to HOW MANY messages I have deleted (this usually
depends on how much spam I've got). I can crash evolution reliably on exit with
lots of spam messages that have been marked for deletion.

Perhaps this points to it being some kind of race condition.
Comment 10 Kevin Verma 2006-11-05 09:29:31 EST
(In reply to comment #8)
> Kevin, can you please attach a backtrace with debugging symbols?  I'd like to
> compare it to the original problem report and make sure you're both hitting the
> same bug.
> 
> Also, FYI, Evolution 2.9 (in Rawhide) seems pretty well-behaved at shutdown.

Sorry for the delay here I am attaching the backtrace, let me know what else you
may require.

I noticed upon crash error message reports that its program ¨calender¨ which had
an issue, but the gnome-force-to-kill covers the pop up too soon.
Comment 11 Kevin Verma 2006-11-05 09:34:23 EST
Created attachment 140392 [details]
evolution-backtrace.txt

evolution-backtrace.txt
Comment 12 Kevin Verma 2006-11-05 15:20:08 EST
Created attachment 140412 [details]
evolution-stderr.txt

I am adding the command line errs and outputs of evolution, as I think this
might help. 

Can you please bumpup the servity of this issue if possible or should I open
another bug ? 

Additional info: I am using google-calenders and two of the local calenders, I
tried disabled those and any claender related plugin but so far none of those
changes helped either.
Comment 13 Matthew Barnes 2006-11-06 11:50:32 EST
Thanks for the additional info, Kevin.

Bug-buddy is just being thick-headed when it reports the application "Calendar"
has crashed.  What's happening is that bug-buddy is using the first menu item it
finds that invokes Evolution.  We have a menu item for each Evolution component
(Mail, Calendar, Tasks, etc.), and guess which one comes first alphabetically. 
It's a known bug.
Comment 14 Kevin Verma 2006-11-06 16:33:50 EST
Ritesh Khadgaray, just pointed out that this is replicating on RHEL5 & 4 with
Garnome, and he pointed me to an upstream fix which just came in : 
http://bugzilla.gnome.org/show_bug.cgi?id=312348
Comment 16 Tim McConnell 2006-11-12 14:26:56 EST
(In reply to comment #13)
> Thanks for the additional info, Kevin.
> 
> Bug-buddy is just being thick-headed when it reports the application "Calendar"
> has crashed.  What's happening is that bug-buddy is using the first menu item it
> finds that invokes Evolution.  We have a menu item for each Evolution component
> (Mail, Calendar, Tasks, etc.), and guess which one comes first alphabetically. 
> It's a known bug.

So would opening a new bug for bug buddy not sending the error report help? I am
having the same issue in FC6 but never had a problem with this in FC 5, I am
having the same problem as Kevin and Motor. If I disable the feature in Edit ->
Preferences -> Mail Preferences -> Empty Trash Folders On Exit, it quits
throwing the error, which I never had that problem in FC5 either. Please let me
know your feelings on the usefulness of creating another bug for the bug buddy
won't report the calendar crash problem. 
Comment 17 Kevin Verma 2006-11-16 07:40:48 EST
I dis-abled the empty trash feature, and started evolution twice, it still
crashes. Any more pointers ? 

(In reply to comment #16)
> (In reply to comment #13)
> > Thanks for the additional info, Kevin.
> > 
> > Bug-buddy is just being thick-headed when it reports the application "Calendar"
> > has crashed.  What's happening is that bug-buddy is using the first menu item it
> > finds that invokes Evolution.  We have a menu item for each Evolution component
> > (Mail, Calendar, Tasks, etc.), and guess which one comes first alphabetically. 
> > It's a known bug.
> 
> So would opening a new bug for bug buddy not sending the error report help? I am
> having the same issue in FC6 but never had a problem with this in FC 5, I am
> having the same problem as Kevin and Motor. If I disable the feature in Edit ->
> Preferences -> Mail Preferences -> Empty Trash Folders On Exit, it quits
> throwing the error, which I never had that problem in FC5 either. Please let me
> know your feelings on the usefulness of creating another bug for the bug buddy
> won't report the calendar crash problem. 

Comment 18 ritz 2006-12-07 08:02:51 EST
bactrace .

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1299186800 (LWP 6305)]
0x006e6af7 in g_list_find () from /lib/libglib-2.0.so.0
(gdb) bt
#0  0x006e6af7 in g_list_find () from /lib/libglib-2.0.so.0
#1  0x02b9c44d in camel_vee_folder_new ()
   from /usr/lib/libcamel-provider-1.2.so.8
#2  0x02b8ecd2 in camel_session_get_service_connected ()
   from /usr/lib/libcamel-provider-1.2.so.8
#3  0x00374e44 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
#4  0x0068a3db in start_thread (arg=0xb28ffb90) at pthread_create.c:296
#5  0x005e406e in ?? () from /lib/libc.so.6


Thread 7 (Thread -1225782384 (LWP 6276)):
#0  0x00771410 in __kernel_vsyscall ()
#1  0x005da503 in *__GI___poll (fds=0x64fff4, nfds=2, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x006ec353 in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0x006ec6c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#4  0x00842624 in libnm_glib_init () from /usr/lib/libnm_glib.so.0
#5  0x00706fcf in g_thread_create_full () from /lib/libglib-2.0.so.0
#6  0x0068a3db in start_thread (arg=0xb6f00b90) at pthread_create.c:296
#7  0x005e406e in ?? () from /lib/libc.so.6

Thread 6 (Thread -1236292720 (LWP 6278)):
#0  0x00771410 in __kernel_vsyscall ()
#1  0x0068e1a6 in ?? () from /lib/libpthread.so.0
#2  0x006cc642 in g_async_queue_sort () from /lib/libglib-2.0.so.0
#3  0x0037482a in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.7
#4  0x00374e99 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
#5  0x0068a3db in start_thread (arg=0xb64fab90) at pthread_create.c:296
#6  0x005e406e in ?? () from /lib/libc.so.6

Thread 5 (Thread -1246782576 (LWP 6279)):
#0  0x00771410 in __kernel_vsyscall ()
#1  0x0068e1a6 in ?? () from /lib/libpthread.so.0
#2  0x006cc642 in g_async_queue_sort () from /lib/libglib-2.0.so.0
#3  0x0037482a in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.7
#4  0x00374e99 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
#5  0x0068a3db in start_thread (arg=0xb5af9b90) at pthread_create.c:296
#6  0x005e406e in ?? () from /lib/libc.so.6

Thread 4 (Thread -1259340912 (LWP 6280)):
#0  0x00771410 in __kernel_vsyscall ()
#1  0x0068e1a6 in ?? () from /lib/libpthread.so.0
#2  0x006cc642 in g_async_queue_sort () from /lib/libglib-2.0.so.0
#3  0x0037482a in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.7
#4  0x00374e99 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
#5  0x0068a3db in start_thread (arg=0xb4effb90) at pthread_create.c:296
#6  0x005e406e in ?? () from /lib/libc.so.6

Thread 3 (Thread -1285289072 (LWP 6298)):
#0  0x00771410 in __kernel_vsyscall ()
#1  0x0068e1a6 in ?? () from /lib/libpthread.so.0
---Type <return> to continue, or q <return> to quit---
#2  0x006cc642 in g_async_queue_sort () from /lib/libglib-2.0.so.0
#3  0x0037482a in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.7
#4  0x00374e99 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
#5  0x0068a3db in start_thread (arg=0xb3640b90) at pthread_create.c:296
#6  0x005e406e in ?? () from /lib/libc.so.6

Thread 2 (Thread -1299186800 (LWP 6305)):
#0  0x006e6af7 in g_list_find () from /lib/libglib-2.0.so.0
#1  0x02b9c44d in camel_vee_folder_new ()
   from /usr/lib/libcamel-provider-1.2.so.8
#2  0x02b8ecd2 in camel_session_get_service_connected ()
   from /usr/lib/libcamel-provider-1.2.so.8
#3  0x00374e44 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
#4  0x0068a3db in start_thread (arg=0xb28ffb90) at pthread_create.c:296
#5  0x005e406e in ?? () from /lib/libc.so.6

Thread 1 (Thread -1208653600 (LWP 6270)):
#0  0x00771410 in __kernel_vsyscall ()
#1  0x005da503 in *__GI___poll (fds=0x64fff4, nfds=13, timeout=495)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x006ec353 in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0x006ec6c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#4  0x036fba23 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#5  0x0805d7ea in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
#6  0x0052cf2c in __libc_start_main (
    main=0x805d410 <POA_GNOME_Evolution_DataServer_InterfaceCheck__fini+55952>,
argc=1, ubp_av=0xbff38fc4, 
    init=0x805df40 <POA_GNOME_Evolution_DataServer_InterfaceCheck__fini+58816>,
fini=0x805df30 <POA_GNOME_Evolution_DataServer_InterfaceCheck__fini+58800>, 
    rtld_fini=0x508390 <_dl_fini>, stack_end=0xbff38fbc) at libc-start.c:231
#7  0x0804f221 in ?? ()
#0  0x006e6af7 in g_list_find () from /lib/libglib-2.0.so.0


---------------------------------------------------------------------------------------------

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208653600 (LWP 6270)]
0x02cf6a6b in xmlOutputBufferWriteString () from /usr/lib/libxml2.so.2
(gdb) bt
#0  0x02cf6a6b in xmlOutputBufferWriteString () from /usr/lib/libxml2.so.2
#1  0x02d9bbac in xmlAttrSerializeTxtContent () from /usr/lib/libxml2.so.2
#2  0x02d9bd7a in xmlAttrSerializeTxtContent () from /usr/lib/libxml2.so.2
#3  0x02d9c381 in xmlSaveTree () from /usr/lib/libxml2.so.2
#4  0x02d9be09 in xmlAttrSerializeTxtContent () from /usr/lib/libxml2.so.2
#5  0x02d9dab6 in xmlNodeDump () from /usr/lib/libxml2.so.2
#6  0x02d9e37d in xmlDocDumpFormatMemoryEnc () from /usr/lib/libxml2.so.2
#7  0x02d9e50f in xmlDocDumpMemory () from /usr/lib/libxml2.so.2
#8  0x0036ce71 in e_account_to_xml () from /usr/lib/libedataserver-1.2.so.7
#9  0x0036b0e6 in e_account_list_save () from /usr/lib/libedataserver-1.2.so.7
#10 0x0036b25b in e_account_list_prune_proxies ()
   from /usr/lib/libedataserver-1.2.so.7
#11 0x062e4bb3 in mail_config_prune_proxies ()
   from /usr/lib/evolution/2.8/components/libevolution-mail.so
#12 0x062e1ca8 in mail_component_get_type ()
   from /usr/lib/evolution/2.8/components/libevolution-mail.so
#13 0x0020a166 in _ORBIT_skel_small_GNOME_Evolution_Component_quit ()
   from /usr/lib/evolution/2.8/libeshell.so.0
#14 0x035057e0 in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#15 0x0020b96e in GNOME_Evolution_Component_quit ()
   from /usr/lib/evolution/2.8/libeshell.so.0
#16 0x0805211b in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
#17 0x006e9916 in g_source_get_current_time () from /lib/libglib-2.0.so.0
#18 0x006e9342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#19 0x006ec31f in g_main_context_check () from /lib/libglib-2.0.so.0
#20 0x006ec6c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#21 0x036fba23 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#22 0x0805d7ea in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
#23 0x0052cf2c in __libc_start_main (
    main=0x805d410 <POA_GNOME_Evolution_DataServer_InterfaceCheck__fini+55952>,
argc=1, ubp_av=0xbff38fc4, 
    init=0x805df40 <POA_GNOME_Evolution_DataServer_InterfaceCheck__fini+58816>,
fini=0x805df30 <POA_GNOME_Evolution_DataServer_InterfaceCheck__fini+58800>, 
    rtld_fini=0x508390 <_dl_fini>, stack_end=0xbff38fbc) at libc-start.c:231
#24 0x0804f221 in ?? ()



(gdb) thread apply all bt

Thread 7 (Thread -1225782384 (LWP 6276)):
#0  0x00771410 in __kernel_vsyscall ()
#1  0x005da503 in *__GI___poll (fds=0x64fff4, nfds=2, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x006ec353 in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0x006ec6c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#4  0x00842624 in libnm_glib_init () from /usr/lib/libnm_glib.so.0
#5  0x00706fcf in g_thread_create_full () from /lib/libglib-2.0.so.0
#6  0x0068a3db in start_thread (arg=0xb6f00b90) at pthread_create.c:296
#7  0x005e406e in ?? () from /lib/libc.so.6

Thread 6 (Thread -1236292720 (LWP 6278)):
#0  0x00771410 in __kernel_vsyscall ()
#1  0x0068e1a6 in ?? () from /lib/libpthread.so.0
#2  0x006cc642 in g_async_queue_sort () from /lib/libglib-2.0.so.0
#3  0x0037482a in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.7
#4  0x00374e99 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
#5  0x0068a3db in start_thread (arg=0xb64fab90) at pthread_create.c:296
#6  0x005e406e in ?? () from /lib/libc.so.6

Thread 5 (Thread -1246782576 (LWP 6279)):
#0  0x00771410 in __kernel_vsyscall ()
#1  0x0068e1a6 in ?? () from /lib/libpthread.so.0
#2  0x006cc642 in g_async_queue_sort () from /lib/libglib-2.0.so.0
#3  0x0037482a in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.7
#4  0x00374e99 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
#5  0x0068a3db in start_thread (arg=0xb5af9b90) at pthread_create.c:296
#6  0x005e406e in ?? () from /lib/libc.so.6

Thread 4 (Thread -1259340912 (LWP 6280)):
#0  0x00771410 in __kernel_vsyscall ()
#1  0x0068e1a6 in ?? () from /lib/libpthread.so.0
#2  0x006cc642 in g_async_queue_sort () from /lib/libglib-2.0.so.0
#3  0x0037482a in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.7
#4  0x00374e99 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
#5  0x0068a3db in start_thread (arg=0xb4effb90) at pthread_create.c:296
#6  0x005e406e in ?? () from /lib/libc.so.6

Thread 3 (Thread -1285289072 (LWP 6298)):
#0  0x00771410 in __kernel_vsyscall ()
#1  0x0068e1a6 in ?? () from /lib/libpthread.so.0
#2  0x006cc642 in g_async_queue_sort () from /lib/libglib-2.0.so.0
#3  0x0037482a in e_msgport_wait () from /usr/lib/libedataserver-1.2.so.7
#4  0x00374e99 in e_msgport_reply () from /usr/lib/libedataserver-1.2.so.7
#5  0x0068a3db in start_thread (arg=0xb3640b90) at pthread_create.c:296
#6  0x005e406e in ?? () from /lib/libc.so.6

Thread 2 (Thread -1299186800 (LWP 6305)):
#0  0x00771410 in __kernel_vsyscall ()
#1  0x0069098e in ?? () from /lib/libpthread.so.0
#2  0x0068c7fc in ?? () from /lib/libpthread.so.0
Previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread -1208653600 (LWP 6270)):
#0  0x02cf6a6b in xmlOutputBufferWriteString () from /usr/lib/libxml2.so.2
#1  0x02d9bbac in xmlAttrSerializeTxtContent () from /usr/lib/libxml2.so.2
#2  0x02d9bd7a in xmlAttrSerializeTxtContent () from /usr/lib/libxml2.so.2
#3  0x02d9c381 in xmlSaveTree () from /usr/lib/libxml2.so.2
#4  0x02d9be09 in xmlAttrSerializeTxtContent () from /usr/lib/libxml2.so.2
#5  0x02d9dab6 in xmlNodeDump () from /usr/lib/libxml2.so.2
#6  0x02d9e37d in xmlDocDumpFormatMemoryEnc () from /usr/lib/libxml2.so.2
#7  0x02d9e50f in xmlDocDumpMemory () from /usr/lib/libxml2.so.2
#8  0x0036ce71 in e_account_to_xml () from /usr/lib/libedataserver-1.2.so.7
#9  0x0036b0e6 in e_account_list_save () from /usr/lib/libedataserver-1.2.so.7
#10 0x0036b25b in e_account_list_prune_proxies ()
   from /usr/lib/libedataserver-1.2.so.7
#11 0x062e4bb3 in mail_config_prune_proxies ()
   from /usr/lib/evolution/2.8/components/libevolution-mail.so
#12 0x062e1ca8 in mail_component_get_type ()
   from /usr/lib/evolution/2.8/components/libevolution-mail.so
#13 0x0020a166 in _ORBIT_skel_small_GNOME_Evolution_Component_quit ()
   from /usr/lib/evolution/2.8/libeshell.so.0
#14 0x035057e0 in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#15 0x0020b96e in GNOME_Evolution_Component_quit ()
   from /usr/lib/evolution/2.8/libeshell.so.0
#16 0x0805211b in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
#17 0x006e9916 in g_source_get_current_time () from /lib/libglib-2.0.so.0
#18 0x006e9342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#19 0x006ec31f in g_main_context_check () from /lib/libglib-2.0.so.0
#20 0x006ec6c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#21 0x036fba23 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#22 0x0805d7ea in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
#23 0x0052cf2c in __libc_start_main (
    main=0x805d410 <POA_GNOME_Evolution_DataServer_InterfaceCheck__fini+55952>,
argc=1, ubp_av=0xbff38fc4, 
    init=0x805df40 <POA_GNOME_Evolution_DataServer_InterfaceCheck__fini+58816>,
fini=0x805df30 <POA_GNOME_Evolution_DataServer_InterfaceCheck__fini+58800>, 
    rtld_fini=0x508390 <_dl_fini>, stack_end=0xbff38fbc) at libc-start.c:231
#24 0x0804f221 in ?? ()
Comment 19 ritz 2006-12-12 18:52:01 EST
bug fix information posted to bug#219362

Comment 20 Kevin Verma 2007-01-03 19:58:50 EST
In reference to https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=219362#c8 :
Is there an update available for FC6 ? any work in progress ? 
Comment 21 Matthew Barnes 2007-01-05 13:27:47 EST
That patch was released in Evolution 2.8.1.1, but was found not to completely
fix the problem.  This is an ongoing issue for upstream.  Please see:

http://bugzilla.gnome.org/show_bug.cgi?id=334966
Comment 22 ritz 2007-05-28 04:06:39 EDT
this issue has been resolved upstream
/me waiting for patch to be merged in :)
Comment 23 Milan Crha 2007-07-17 12:08:56 EDT
Fixed in evolution-2.10.3-1.fc7

Note You need to log in before you can comment on or make changes to this bug.