Bug 212418 - CVS_PROXY doesn't work with cvs-1.11.22-4
Summary: CVS_PROXY doesn't work with cvs-1.11.22-4
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cvs (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jindrich Novy
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 213189
TreeView+ depends on / blocked
 
Reported: 2006-10-26 18:35 UTC by H.J. Lu
Modified: 2013-07-02 23:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-04 20:35:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description H.J. Lu 2006-10-26 18:35:42 UTC
I have

export CVS_PROXY=http://xxx:911

It works with cvs-1.11.22-2.FC5 in FC5. Strace shows

onnect(3, {sa_family=AF_INET, sin_port=htons(911), sin_addr=inet_addr("xxx")},
16) = 0

But cvs-1.11.22-4 tries

connect(3, {sa_family=AF_INET, sin_port=htons(2401), sin_addr=inet_addr("xxx")},
16) = 0

It ignores port 911 in CVS_PROXY.

Comment 1 Jindrich Novy 2006-10-27 10:33:20 UTC
Could you please write a cvs command line you are using for straces? The problem
is likely caused by the newly added IPv6 patch.

Comment 2 H.J. Lu 2006-10-27 15:03:55 UTC
I used

# strace cvs -z 3 -d :pserver:anonymous@cvs.fedora.redhat.com:/cvs/dist co make

Comment 3 Jindrich Novy 2006-10-28 19:01:16 UTC
Fixed in rawhide. FC5 update is comming soon.

Comment 4 Fedora Update System 2006-10-30 21:39:35 UTC
cvs-1.11.22-6.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 5 Fedora Update System 2006-10-30 21:39:52 UTC
cvs-1.11.22-6.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 6 H.J. Lu 2006-10-30 22:03:02 UTC
cvs-1.11.22-4 in RHEL5 beta has the same issue.

Comment 7 Fedora Update System 2006-11-03 17:29:40 UTC
cvs-1.11.22-6.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 8 Fedora Update System 2006-11-03 17:30:09 UTC
cvs-1.11.22-6.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 9 H.J. Lu 2006-11-04 18:39:17 UTC
I have verified that both cvs-1.11.22-6.fc6 and cvs-1.11.22-6.fc5 work
correctly with CVS_PROXY.

Comment 10 Jindrich Novy 2006-11-04 20:35:24 UTC
Thanks!


Note You need to log in before you can comment on or make changes to this bug.