Bug 212439 - Pentium 4 frequency scaling still not working correctly
Pentium 4 frequency scaling still not working correctly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 15:26 EDT by Ronny Fischer
Modified: 2015-01-04 17:29 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 15:22:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronny Fischer 2006-10-26 15:26:35 EDT
Description of problem:

The kernel module "p4_clockmod" still doesn't work correctly. There are only 
two states of frequency scaling available.

Version-Release number of selected component (if applicable):

Fedora Core 6, Kernel 2.6.18-1.2798 (i686)

How reproducible:

always

Steps to Reproduce:
1. load the "p4_clockmod" module on system with Pentium 4 processor
2. try to adjust the the frequency
3.
  
Actual results:

only the two highest states (out of eight) are available

Expected results:

the processor should scale its frequency in eight different states

Additional info:

I mentioned the same bug in in FC5 before. It was said that this problem will 
be fixed with the release of kernel 2.6.18 and/or FC6. The bug report was 
closed, but now we have a new kernel and FC6, but the problem remains.

I also reported that the cpufreq scaling worked correctly under FC4.

The bug was also reported by Pat Gardner for FC5 (https://bugzilla.redhat.com/
bugzilla/show_bug.cgi?id=192201).

I hope you will do somethig soon.

Regards,

Ronny Fischer
Comment 1 Gregory Gulik 2006-10-28 11:58:17 EDT
I had reported frequency scaling not working but upgrading the kernel manually
to the i686 version fixed it in most cases.  However I do have one laptop in
which frequency scaling still does not work even with the i686 kernel.  As the
previous poster noted, this laptop did not have functional frequency scaling in
FC5 with either the 2.6.17 or 2.6.18 based kernels.  Frequency scaling DID work
with prior kernels.

The information about this particular laptop/cpu is:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Mobile Intel(R) Celeron(R) CPU 1.50GHz
stepping        : 4
cpu MHz         : 1495.705
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm up
bogomips        : 2994.74

The kernel running currently is:
Linux toshiba1115 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006 i686
i686 i386 GNU/Linux

I had upgraded the kernel to the i686 version with:
rpm --force -Uhv kernel-2.6.18-1.2798.fc6.i686.rpm

Yet cpuspeed still does not work:
# service cpuspeed restart
cat: /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver: No such file or directory
WARNING: Error inserting freq_table
(/lib/modules/2.6.18-1.2798.fc6/kernel/drivers/cpufreq/freq_table.ko): Operation
not permitted
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device
Comment 2 Dave Jones 2006-10-28 15:00:48 EDT
Ron: It stopped working for some folks when an errata workaround was added. It
intentionally limits some frequencies which can be problematic on some systems,
but aparently that needs revisiting as it limits too many. I'll poke the people
who submitted that patch to revisit it.

Greg: You have a completely different problem. It looks like you haven't set
DRIVER="p4-clockmod" in your /etc/cpuspeed.conf.  You have to set this up
manually as using p4-clockmod is something that a user must decide to do due to
the performance impact using it implies.
Comment 3 Gregory Gulik 2006-10-30 10:19:20 EST
Changing the DRIVER did work on this particular laptop.  It seems to me that
should somehow be automated.  Is there any way to have cpuspeed automatically
detect and use the correct driver?
Comment 4 Ronny Fischer 2007-03-15 15:22:49 EDT
Dear Dave and all the others.

With the realease of Kernel 2.6.20 for Fedora Core 6 (in fact today) the 
frequency scaling is working correctly now. All eight cCPU clock states are 
available. I wonder what you have done to make it? Hope it won't fail again...

Great work an thx a lot

Ronny
Comment 5 Gregory Gulik 2007-03-16 09:54:38 EDT
I checked on my Mobile Intel(R) Celeron(R) CPU 1.50GHz based Toshiba notebook
and once again frequency scaling is working as of the 2.6.20 kernel update that
came out yesterday.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.