This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 212443 - 60-fuse.rules error at boot in udev
60-fuse.rules error at boot in udev
Status: CLOSED DUPLICATE of bug 208343
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 15:49 EDT by Mace Moneta
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 10:04:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mace Moneta 2006-10-26 15:49:23 EDT
Description of problem:

At boot, udev complains:

Oct 26 14:41:26 buggsb udevd[398]: add_to_rules: invalid KERNEL operation
Oct 26 14:41:26 buggsb udevd[398]: add_to_rules: invalid rule
'/etc/udev/rules.d/60-fuse.rules:1'

As a result, /dev/fuse has incorrect permissions.

Version-Release number of selected component (if applicable):

fuse-2.5.3-4.fc6

How reproducible:

Always

Steps to Reproduce:
1. Install fuse, and a filesystem (e.g., fuse-sshfs)
2. Add a user to the fuse group
3. Reboot

  
Actual results:

Can't use fuse filesystem, because of incorrect permissions

Expected results:

Successful mount

Additional info: It looks like the syntax error is an "=" instead of an "==" in
/etc/udev/rules.d/60-fuse.rules.
Comment 1 Jason Farrell 2006-10-26 23:05:51 EDT
I see the same error at boot. a "chmod 660 /dev/fuse" allows sshfs to work
temporarily, but the udev rule needs to updated for subsequent boots.
Comment 2 Harald Hoyer 2006-10-27 03:23:16 EDT
/etc/udev/rules.d/60-fuse.rules is not part of the udev component..

Query the Component with
$ rpm -qf /etc/udev/rules.d/60-fuse.rules
Comment 3 Mace Moneta 2006-10-27 09:46:31 EDT
/etc/udev/rules.d/60-fuse.rules is part of the 'fuse' package, but bugzilla
doesn't list a fuse component, so I picked udev as the closest match.
Comment 4 Russell Harrison 2006-10-27 19:11:06 EDT
I'm also seeing this problem on the released version of FC6
Comment 5 Dawid Gajownik 2006-10-29 10:04:09 EST

*** This bug has been marked as a duplicate of 208343 ***

Note You need to log in before you can comment on or make changes to this bug.