Bug 212458 - Storage test not planned for HP Proliant DL585 with RAID cciss
Storage test not planned for HP Proliant DL585 with RAID cciss
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: YangKun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 16:43 EDT by Greg Nichols
Modified: 2008-07-16 17:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 04:29:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2006-10-26 16:43:19 EDT
HTS does not identify that storage tests are needed for an HP585DL G1,
with RAID via ccis.
Comment 1 Greg Nichols 2006-10-27 12:20:06 EDT
Fixed storage test to be planned if a cciss PCI device is found.   The test 
does not run correctly for RAID - See RHR2 test.
Comment 3 YangKun 2006-11-02 04:29:25 EST
The problem is storage test doesn't find this "cciss" device, fixed it now.
Please see the following details:
-------------------------------------------
<17:29:51 kun@yangkun>$ diff -uNr storage.sh.orig storage.sh
--- storage.sh.orig     2006-11-02 17:28:35.000000000 +0800
+++ storage.sh  2006-11-02 17:29:51.000000000 +0800
@@ -135,7 +135,9 @@

 # find the storage devices     -YangKun
 get_storage_info() {
-    hal-device |  fgrep block.device | awk '{print $3}' | tr -d "'"[0-9] |
colrm 1 5 | sort -u
+    # use another way to find storgae info          # YK
+    /sbin/fdisk -l |  grep Disk | awk '{print $2}' | tr -d ":" | colrm 1 5 |
sort -u
+#    hal-device |  fgrep block.device | awk '{print $3}' | tr -d "'"[0-9] |
colrm 1 5 | sort -u
 }
 STORAGE_DEVICES=`get_storage_info`

@@ -262,7 +264,7 @@
         if [ "$testdev" == "$swapdev" ]; then restore_swap $swapdev; fi

         # remove temp directories      -YangKun
-        rmdir $device.*
+        #rmdir $device.* 2>/dev/null

       fi
     done
<17:29:56 kun@yangkun>$

Note You need to log in before you can comment on or make changes to this bug.