Bug 212463 - linux/config.h is missing from kernel-devel
linux/config.h is missing from kernel-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 16:49 EDT by Trevin Beattie
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-27 16:00:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Trevin Beattie 2006-10-26 16:49:04 EDT
Description of problem:
The file include/linux/config.h is not found in
/usr/src/kernels/2.6.18-1.2798.fc6-x86_64/.  It was present in the last release
candidate (2.6.17-1.2630.fc6).  This file is required to build a 3rd-party
kernel module (fglrx).

Version-Release number of selected component (if applicable):
kernel-devel-2.6.18-1.2798.fc6


Steps to Reproduce:
Try building the ATI fglrx 8.29.6:
# ./ati-driver-installer-8.29.6.run --buildpkg Fedora/FC6


Actual results:
...
make[1]: Entering directory `/usr/src/kernels/2.6.18-1.2798.fc6-x86_64'
  CC [M] 
/tmp/ATI-fglrx-8.29.6-1-5399-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/tmp/ATI-fglrx-8.29.6-1-5399-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:92:26:
error: linux/config.h: No such file or directory
...
make[2]: ***
[/tmp/ATI-fglrx-8.29.6-1-5399-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o]
Error 1
make[1]: ***
[_module_/tmp/ATI-fglrx-8.29.6-1-5399-root/tmp/ATI-fglrx-8.29.6-1.fc6-root-root/lib/modules/fglrx/build_mod/2.6.x]
Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.18-1.2798.fc6-x86_64'
make: *** [kmod_build] Error 2
build failed with return value 2


Expected results:
kernel-module-ATI-fglrx-2.6.18-1.2798.fc6-8.29.6-1.fc6.x86_64.rpm
Comment 1 Trevin Beattie 2006-10-26 17:02:17 EDT
Downgrading the severity since I have found a very simple workaround for the
problem.  The file
/usr/src/kernels/2.6.18-1.2798.fc6-x86_64/include/linux/config.h can be created
by hand with the following contents:

#ifndef _LINUX_CONFIG_H
#define _LINUX_CONFIG_H
#include <linux/autoconf.h>
#endif
Comment 2 Mike A. Harris 2006-10-27 06:18:31 EDT
http://www.phoronix.com/redblog/?p=blog&i=NTUwMA


This bug should be closed NOTABUG now
Comment 3 Jarod Wilson 2006-10-27 16:00:31 EDT
What Mike said.

Note You need to log in before you can comment on or make changes to this bug.