Bug 212492 - Display warning page if dup bug has different project, version, or component fields
Display warning page if dup bug has different project, version, or component ...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
devel
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Matt Tyson
tools-bugs
: FutureFeature, Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 20:12 EDT by Prarit Bhargava
Modified: 2013-06-24 00:16 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.2.4-7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 19:44:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-10-26 20:12:39 EDT
Description of problem:

This is more of a feature request/enhancement ...

I should not be allowed to dup BZs that are in different versions of software
product, or maybe it should give me a loud warning.

I admit that sometimes I get lazy or I forget to check the version field before
I dup a RHEL4 bug to a RHEL5 bug, etc., so it would be nice to have a warning
come up saying that I'm about to do something incredibly dumb ;)

I've noticed this happen in some other BZs so maybe I'm not the only one who
gets in trouble for doing this :)

See comments in bug 207002.

P.
Comment 1 Roland McGrath 2006-10-26 20:36:33 EDT
After haranguing Prarit, I was just going to file this same RFE wrt differing
Product fields, or even just specific prohibition on Fedora vs RHEL matching
since RHEL Beta vs RHEL product is often valid (as is Fedora N vs Fedora devel
version fields sometimes).
Comment 2 Prarit Bhargava 2006-10-26 20:42:15 EDT
>or even just specific prohibition on Fedora vs RHEL matching

I'm not so sure that works.  There are times when RHEL-devel == Fedora-devel and
we do dup bugs against each other.  A prohibition is probably too strong -- I
think a loud warning would suffice and a "Are you really sure you want to do
this?" button would be nice :)

P.
Comment 4 Simon Green 2012-05-10 09:12:56 EDT
Is this enhancement still wanted?

  -- simon
Comment 5 Prarit Bhargava 2012-05-10 09:20:53 EDT
(In reply to comment #4)
> Is this enhancement still wanted?
> 

Yes, I think it is still a good idea.  We still occasionally have engineers who accidentally do this.

P.
Comment 6 Simon Green 2012-05-11 00:46:08 EDT
(In reply to comment #5)
> Yes, I think it is still a good idea.  We still occasionally have engineers who
> accidentally do this.

Fair enough. It will be a warning page rather than a complete block.
Comment 7 Jeff Fearn 2012-05-30 01:47:44 EDT
There should be a preference to disable this warning if a user doesn't want it.

This feature should be added to a major release so that time can be provided to warn users of the change in functionality.
Comment 8 Simon Green 2012-09-10 19:16:00 EDT
Moving to the next release as this wasn't completed on time for release 5.

  -- simon
Comment 12 Simon Green 2012-11-18 22:36:46 EST
Turns out this part wasn't implemented "There should be a preference to disable this warning if a user doesn't want it.". There was also a bug which QE identified today as well ( https://bugzilla.redhat.com/show_bug.cgi?id=877547#c5 )

  -- simon
Comment 15 Simon Green 2012-11-20 17:25:19 EST
Two things need to be fixed as part of release 7.

1) On the warning page, the links to the bug numbers are not valid.

2) You don't need a separate parameter section for this, it should be in the 'Bug Change Policies' section.

Note You need to log in before you can comment on or make changes to this bug.