Bug 212493 - drive letter reversal confounds ieee1394 update with an SATA hard drive
drive letter reversal confounds ieee1394 update with an SATA hard drive
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 20:15 EDT by Joseph Teichman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 10:22:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Teichman 2006-10-26 20:15:56 EDT
Description of problem:
When attaching a firewire/IEEE1394 disk with installation media on it and also
having present a SATA hard drive, the hard drive will show up as sdb and the
firewire drive will show up as sda. This is a problem when attempting to perform
an update to an existing fedora installation. The /etc/fstab will be read, but
the information in it will refer to the hard disk as sda. This will cause the
installation to fail when it cannot use the swap partition.

How reproducible:
Every time I have attempted on this system to use an IEEE1394 disk with the
installation media on it - even when first booting with a CD Rom and using
"askmethod" to use the media on the CD.


Steps to Reproduce:
1. Install previous version of Fedora (I used version 5)
2. Plug in Firewire drive
3. Put boot CD into CD Rom drive
4. Boot using "linux askmethod"
5. When the box comes up for selecting the location of the boot media, it will
be apparent that the drive associations got reversed 

Actual results:
My SATA hard drive was shown as sdb and my firewire drive was shown as sda

Expected results:
The SATA drive should have showed up as sda which it normally 
is and the firewire drive should have been sdb, which it always is.

Additional info:
I have not attempted this, but it may be possible to work around this by booting
into the installer first and then plugging in the firewire drive before the
selection window for "askmethod" comes up.
Comment 1 Jeremy Katz 2006-10-30 14:23:55 EST
What does your /etc/fstab look like?  
Comment 2 Joseph Teichman 2006-10-31 01:26:30 EST
Partition labels would help work around the problem for the regular disk
partitions. However, it fails on trying to use the swap partition, for which it
is not possible (AFAIK) to use partition labels.
My external removable disk can be connected either as a Firewire disk or a USB
disk. I was able to work around this problem by attaching the removable disk as
a USB disk instead of a Firewire disk. When I used it as a USB disk, it showed
up as /dev/sdb.
Anyway, here is my fstab:  

LABEL=/                 /                       ext3    defaults        1 1
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
LABEL=/home             /home                   ext3    defaults        1 2
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
LABEL=/var              /var                    ext3    defaults        1 2
/dev/sda8               swap                    swap    defaults        0 0
/dev/sda1               /mnt/sda1               ext3    noauto          0 3
/dev/sda9               /mnt/sda9               ext3    noauto          0 3
Comment 3 Jeremy Katz 2006-10-31 10:22:39 EST
swap can be labelled too and has been by default since FC3.  This is why we use
labels instead of the device names as device names aren't at all guaranteed to
be persistent (and we can't load the firewire modules later as they may be
needed for driver disks or the like)

Note You need to log in before you can comment on or make changes to this bug.