Bug 212505 - Xen: kernel unaligned access
Xen: kernel unaligned access
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.0
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Aron Griffis
:
: 212536 212645 219209 (view as bug list)
Depends On: 204011
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 22:23 EDT by Aron Griffis
Modified: 2010-10-22 02:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 20:45:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aron Griffis 2006-10-26 22:23:44 EDT
+++ This bug was initially created as a clone of Bug #204011 +++

Description of problem:
We have some error message by using network on guest OS.
kernel unaligned access to 0xe0000000187a4e1e, ip=0xa0000001004fad50

Version-Release number of selected component (if applicable):
My environment is;
- dom0/domU kernel
   http://hg.et.redhat.com/kernel/linux-2.6-xen-fedora cset #35247
- xen & tools
   http://xenbits.xensource.com/ext/xen-ia64-unstable.hg cset #11048
- Machine
   FedoraCore2 test2 on Tiger4 

How reproducible:
Always

Steps to Reproduce:
1. On domU, network is enabled. 
2.
3.
  
Actual results:        
kernel unaligned access to 0xe0000000187a4e1e, ip=0xa0000001004faed0
kernel unaligned access to 0xe0000000187a4e2e, ip=0xa0000001004fb130
kernel unaligned access to 0xe0000000187a4e1e, ip=0xa0000001004fb2e0
kernel unaligned access to 0xe00000001662921e, ip=0xa0000001004fad50
kernel unaligned access to 0xe00000001662921e, ip=0xa0000001004fae21
kernel unaligned access to 0xe00000001662921e, ip=0xa0000001004faed0
kernel unaligned access to 0xe00000001662922e, ip=0xa0000001004fb130
kernel unaligned access to 0xe00000001662921e, ip=0xa0000001004fb2e0
kernel unaligned access to 0xe0000000187a5e1e, ip=0xa0000001004fad50
kernel unaligned access to 0xe0000000187a5e1e, ip=0xa0000001004fae21
kernel unaligned access to 0xe0000000187a5e1e, ip=0xa0000001004faed0
kernel unaligned access to 0xe0000000187a5e2e, ip=0xa0000001004fb130
kernel unaligned access to 0xe0000000187a5e1e, ip=0xa0000001004fb2e0
kernel unaligned access to 0xe00000000df1a61e, ip=0xa0000001004fad50
kernel unaligned access to 0xe00000000df1a61e, ip=0xa0000001004fae21
kernel unaligned access to 0xe00000000df1a61e, ip=0xa0000001004faed0
kernel unaligned access to 0xe00000000df1a62e, ip=0xa0000001004fb130
kernel unaligned access to 0xe00000000df1a61e, ip=0xa0000001004fb2e0
kernel unaligned access to 0xe0000000187a501e, ip=0xa0000001004fad50
kernel unaligned access to 0xe0000000187a501e, ip=0xa0000001004fae21
kernel unaligned access to 0xe0000000187a501e, ip=0xa0000001004faed0
kernel unaligned access to 0xe0000000187a502e, ip=0xa0000001004fb130
kernel unaligned access to 0xe0000000187a501e, ip=0xa0000001004fb2e0

Expected results:
Not access unaligned memory and there are no error messages


Additional info:

-- Additional comment from takebe_akio@jp.fujitsu.com on 2006-10-18 20:47 EST --
This problem is fixed at changeset 11815 of xen-ustable.hg.

Please apply the following patch.
http://xenbits.xensource.com/xen-unstable.hg?cs=797430d25f1b

Best Regards,

Akio Takebe

-- Additional comment from agriffis@redhat.com on 2006-10-26 22:20 EST --
Created an attachment (id=139548)
ported from xen-unstable.hg to kernel-2.6.18-1.2736.el5
Comment 1 Stephen Tweedie 2006-10-27 06:35:47 EDT
*** Bug 212536 has been marked as a duplicate of this bug. ***
Comment 3 RHEL Product and Program Management 2006-11-15 10:02:22 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Larry Troan 2006-11-20 14:38:57 EST
Per discussion with Prarit and Aron,
> Bug 212505: 
> Status-NEW, patch attached
Should be in RHEL5.0 before RC.

Aron, please ACK for devel; QA plewease ACK/NAK accordingly.
Comment 5 Jay Turner 2006-11-20 16:07:57 EST
QE ack for RHEL5.
Comment 6 Larry Troan 2006-11-28 10:50:45 EST
Ping devel...... 
Aron, please provide devel ACK and change status to ASSIGNED so we can escalate
for 5.0 consideration. since patch is available/attached.
Comment 9 Larry Troan 2006-12-03 21:14:03 EST
Escalating for RHEL5.0 consideration per Thursday's RHEL5 meeting.

We need a DEVEL ACK (Aron/Prarit or your management). 
Patch available. Changing bug to ASSIGNED.
Comment 10 Aron Griffis 2006-12-04 16:56:54 EST
Devel ACK
Comment 11 Aron Griffis 2006-12-05 13:13:24 EST
*** Bug 212645 has been marked as a duplicate of this bug. ***
Comment 13 Don Zickus 2006-12-06 18:04:27 EST
in 2.6.18-1.2839.el5
Comment 14 Herbert Xu 2006-12-11 17:46:43 EST
*** Bug 219209 has been marked as a duplicate of this bug. ***
Comment 15 RHEL Product and Program Management 2006-12-22 20:45:56 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.