Bug 212514 - aiGLX extension has PowerPC endian bug (screen blue/purple when enabled)
aiGLX extension has PowerPC endian bug (screen blue/purple when enabled)
Status: CLOSED DUPLICATE of bug 210760
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
https://launchpad.net/distros/ubuntu/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-27 01:14 EDT by Edward Rudd
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-15 01:23:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 8095 None None None Never

  None (edit)
Description Edward Rudd 2006-10-27 01:14:15 EDT
Description of problem:
with AIGLX extensions enabled, the screen appears bluish purple on powerPC
architectures due to an endianess bug.

This supposedly has been fixed upstream.. and several threads/bug reports exist
on debian and freedesktop.org about the issue.

https://launchpad.net/distros/ubuntu/+source/compiz/+bug/58373
Comment 1 Andrew Alm 2006-10-27 02:23:29 EDT
This is definately a problem on ppc.  I found a patch to it on the debian bug
report site. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=392453

I tried applying this patch and moving the new libglx.so over to no avail,
hoefully someone with more knowledge on Xorg can get this fixed.
Comment 2 Matthew Hall 2006-10-30 11:57:38 EST
I can confirm rebuilding xorg-X11-server with the debian patch
(http://gitweb.freedesktop.org/?p=xorg/xserver.git;a=commitdiff;h=3ad1642f1bbaa5f96558cdf3384b40f7122f8781O)
does fix this issue.

There is a separate issue with some window border corruption after
suspend/resume - but that's a different bug (restarting compiz fixes this).
Comment 3 Adam Thompson 2006-11-14 10:20:17 EST
Just confirming that it occurs on my PowerBook G4 15", too.  Eagerly awaiting
the patch :-)
Comment 4 Frank Arnold 2006-11-15 01:23:34 EST
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 210760 ***

Note You need to log in before you can comment on or make changes to this bug.