Bug 212536 - Xen: kernel unaligned access
Xen: kernel unaligned access
Status: CLOSED DUPLICATE of bug 212505
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
:
Depends On: 204011
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-27 06:29 EDT by Stephen Tweedie
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-27 06:35:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2006-10-27 06:29:37 EDT
+++ This bug was initially created as a clone of Bug #204011 +++

Description of problem:
We have some error message by using network on guest OS.
kernel unaligned access to 0xe0000000187a4e1e, ip=0xa0000001004fad50

Version-Release number of selected component (if applicable):
My environment is;
- dom0/domU kernel
   http://hg.et.redhat.com/kernel/linux-2.6-xen-fedora cset #35247
- xen & tools
   http://xenbits.xensource.com/ext/xen-ia64-unstable.hg cset #11048
- Machine
   FedoraCore2 test2 on Tiger4 

How reproducible:
Always

Steps to Reproduce:
1. On domU, network is enabled. 
2.
3.
  
Actual results:        
kernel unaligned access to 0xe0000000187a4e1e, ip=0xa0000001004faed0
kernel unaligned access to 0xe0000000187a4e2e, ip=0xa0000001004fb130
kernel unaligned access to 0xe0000000187a4e1e, ip=0xa0000001004fb2e0
kernel unaligned access to 0xe00000001662921e, ip=0xa0000001004fad50
kernel unaligned access to 0xe00000001662921e, ip=0xa0000001004fae21
kernel unaligned access to 0xe00000001662921e, ip=0xa0000001004faed0
kernel unaligned access to 0xe00000001662922e, ip=0xa0000001004fb130
kernel unaligned access to 0xe00000001662921e, ip=0xa0000001004fb2e0
kernel unaligned access to 0xe0000000187a5e1e, ip=0xa0000001004fad50
kernel unaligned access to 0xe0000000187a5e1e, ip=0xa0000001004fae21
kernel unaligned access to 0xe0000000187a5e1e, ip=0xa0000001004faed0
kernel unaligned access to 0xe0000000187a5e2e, ip=0xa0000001004fb130
kernel unaligned access to 0xe0000000187a5e1e, ip=0xa0000001004fb2e0
kernel unaligned access to 0xe00000000df1a61e, ip=0xa0000001004fad50
kernel unaligned access to 0xe00000000df1a61e, ip=0xa0000001004fae21
kernel unaligned access to 0xe00000000df1a61e, ip=0xa0000001004faed0
kernel unaligned access to 0xe00000000df1a62e, ip=0xa0000001004fb130
kernel unaligned access to 0xe00000000df1a61e, ip=0xa0000001004fb2e0
kernel unaligned access to 0xe0000000187a501e, ip=0xa0000001004fad50
kernel unaligned access to 0xe0000000187a501e, ip=0xa0000001004fae21
kernel unaligned access to 0xe0000000187a501e, ip=0xa0000001004faed0
kernel unaligned access to 0xe0000000187a502e, ip=0xa0000001004fb130
kernel unaligned access to 0xe0000000187a501e, ip=0xa0000001004fb2e0

Expected results:
Not access unaligned memory and there are no error messages


Additional info:

-- Additional comment from takebe_akio@jp.fujitsu.com on 2006-10-18 20:47 EST --
This problem is fixed at changeset 11815 of xen-ustable.hg.

Please apply the following patch.
http://xenbits.xensource.com/xen-unstable.hg?cs=797430d25f1b

Best Regards,

Akio Takebe

-- Additional comment from agriffis@redhat.com on 2006-10-26 22:20 EST --
Created an attachment (id=139548)
ported from xen-unstable.hg to kernel-2.6.18-1.2736.el5
Comment 1 Stephen Tweedie 2006-10-27 06:35:25 EDT

*** This bug has been marked as a duplicate of 212505 ***

Note You need to log in before you can comment on or make changes to this bug.