Bug 212566 - Crashes trying to set File Properties
Crashes trying to set File Properties
Status: CLOSED DUPLICATE of bug 203472
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
6
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-27 10:46 EDT by Fernando Fernandez Pedraza
Modified: 2014-03-16 23:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-27 11:24:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fernando Fernandez Pedraza 2006-10-27 10:46:10 EDT
Description of problem:
Program crashes trying to set File-->Properties

Version-Release number of selected component (if applicable):
gnucash-2.0.1-6.fc6
scim-libs-1.4.4-35.fc6
scim-1.4.4-35.fc6

How reproducible:
Always

Steps to Reproduce:
1.Open file->properties  
2.write anything in any field (like "Fernando" in the error message below)
3.apply
  
Actual results:
Program crashes

Expected results:
Program continues normally

Additional info:
Looks like scim related. Tried both with and without scim installed. (I don't
need it). Locale is spanish.


This is the error message: Backtrace:
In unknown file:
   ?:  0* [apply-cb]
In /usr/share/gnucash/guile-modules/gnucash/gnome-utils.scm:
  29:  1* [gnc:options-scm->kvp #<procedure dispatch #> # # ...]
In /usr/share/gnucash/scm/options.scm:
1471:  2  [scm->kvp #<gw:wcp <gnc:kvp-frame*> 0x815570> ("options")]
In unknown file:
    ...
   ?:  3  [hash-for-each #<procedure #f (section hash)> #(() () () ...)]
In /usr/share/guile/site/slib/hashtab.scm:
 120:  4  (do ((i (+ -1 #) (+ -1 i))) ((negative? i)) ...)
 122:  5* [alist-for-each #<procedure #f (section hash)> (("Business" . #))]
In /usr/share/guile/site/slib/alist.scm:
 117:  6  [for-each #<procedure #f (pair)> (("Business" . #(() () () ...)))]
In unknown file:
   ?:  7* [#<procedure #f (pair)> ("Business" . #(() () () (#) (#) () () () ()
...))]
In /usr/share/guile/site/slib/alist.scm:
 117:  8* [#<procedure #f (section hash)> "Business" #(() () () ...)]
In /usr/share/gnucash/scm/options.scm:
1299:  9  [section-for-each #(() () () ...) #<procedure #f (option)>]
In unknown file:
    ...
   ?: 10  [hash-for-each #<procedure #f (name option)> #(() () () ...)]
In /usr/share/guile/site/slib/hashtab.scm:
 120: 11  (do ((i (+ -1 #) (+ -1 i))) ((negative? i)) ...)
 122: 12* [alist-for-each #<procedure #f (name option)> (# #)]
In /usr/share/guile/site/slib/alist.scm:
 117: 13  [for-each #<procedure #f (pair)> (# #)]
In unknown file:
   ?: 14* [#<procedure #f (pair)> ("Company Name" . #)]
In /usr/share/guile/site/slib/alist.scm:
 117: 15* [#<procedure #f #> "Company Name" #]
In /usr/share/gnucash/scm/options.scm:
1295: 16  [#<procedure #f (option)> #("Business" "Company Name" "a" ...)]
    ...
 199: 17  [gnc:kvp-frame-set-slot-path # {"Fernando"} #]

/usr/share/gnucash/scm/options.scm:199:20: In procedure exact? in expression
(gnc:kvp-frame-set-slot-path f value ...):
/usr/share/gnucash/scm/options.scm:199:20: Wrong type argument in position 1:
"Fernando"
Comment 1 Bill Nottingham 2006-10-27 11:24:53 EDT

*** This bug has been marked as a duplicate of 203472 ***

Note You need to log in before you can comment on or make changes to this bug.