Bug 212595 - luci - probing of storage on remote system can result in luci zope process tying up 90% of memory
luci - probing of storage on remote system can result in luci zope process ty...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-27 13:27 EDT by Len DiMaggio
Modified: 2009-04-16 18:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-23 11:41:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Len DiMaggio 2006-10-27 13:27:49 EDT
Description of problem:
luci and ricci - probing of storage on remote system can result in luci zope
process tying up 90% of memory - the process is also not killed when the luci
service is stopped.

This may be (partially?) due to network delays, but I'm seeing situations where
an attempt to probe the storage of a remote node (i.e., a node other than the
node running luci - although all the nodes are local to the same subnet) can
take several (10+) minutes. At this point, this process ties up 90%+ of the
system's memory:

/usr/bin/python /usr/lib/luci/zope/lib/python/Zope2/Startup/run.py -C
/var/lib/luci/etc/zope.conf

Stopping the luci service does not kill this process. 

Version-Release number of selected component (if applicable):
luci-0.8-21.el5 and ricci-0.8-21.el5

How reproducible:
~75% of the time

Steps to Reproduce:
1. Access storage of a remote system via luci 
  
Actual results:
Storage information is not reported by luci - zope process listed above ties up
90% of memory.

Expected results:
The storage should be reported - if it's a network timing issue, we should have
a timeout.

Additional info:
Comment 2 Len DiMaggio 2007-01-23 11:54:09 EST
Unable to recreate this problem with:
luci-0.8-29.el5
ricci-0.8-29.el5

Marking the bz as verified.

Note You need to log in before you can comment on or make changes to this bug.