Bug 212602 - psselect return value should indicate if no pages were written
psselect return value should indicate if no pages were written
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: psutils (Show other bugs)
5
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tomas Smetana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-27 13:57 EDT by Steve Friedman
Modified: 2008-01-31 06:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 06:49:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Friedman 2006-10-27 13:57:09 EDT
Description of problem:
It would be convenient if psselect would indicate via the return value
(and not just the emitted text) whether any pages were selected.

Version-Release number of selected component (if applicable):
psutils-1.17-25.2.1

How reproducible:
This is a feature request -- it occurs every time.

Steps to Reproduce:
1. psselect 10000 small.ps small-page10000.ps should return a different
value than psselect 1 big.ps big-page1.ps
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Tkac 2006-10-31 03:51:41 EST
What means "different value"? If it's different return value it can't be
different. Return value 0 indicates that psselect ends correctly. And it is same
for psselect 10000 small.ps small-page10000.ps and psselect 1 big.ps
big-page1.ps. Return value other than 0 is impossible because values other than
0 indicating error
Comment 2 Steve Friedman 2006-10-31 10:35:51 EST
I was proposing that not selecting any pages is off-normal and thus should not
return with 0.  Since the return value is bi-value, we must convert the normal /
warning / error condition to normal / off-normal by conflating warnings with
normal or with error.  I prefer the latter to the former.  Could you accept a
command-line switch to determine which the user prefers?
Comment 3 Tomas Smetana 2008-01-30 06:15:47 EST
Another forgotten bug... Do you still want this to be implemented?  Sorry to ask
that silly but adding an option is API breakage and if it's not required it
would be better to avoid.
Comment 4 Steve Friedman 2008-01-30 11:45:12 EST
I've moved on to a different company, so I no longer use this particular package
(let alone function).  I still believe that this feature would be useful, but
understand if you decided to mark it WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.