Bug 212708 - Cannot mount ufs partitons from FC6 x86_64 on a dual boot linux/solaris machine
Cannot mount ufs partitons from FC6 x86_64 on a dual boot linux/solaris machine
Status: CLOSED DUPLICATE of bug 209921
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 04:17 EDT by Rami Rosen
Modified: 2015-01-04 17:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 12:13:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rami Rosen 2006-10-28 04:17:17 EDT
Description of problem:
cannot mount ufs solaris partition from linux x86_64 with FC6

Version-Release number of selected component (if applicable):
2.6.18-1.2798.fc6xen kernel

How reproducible:
On x86_64 machine : boot into the FC6 partition on a dual boot machine where
there is solaris installed as the boot partition.
(important: First solaris was installed, then linux ! NOT vice versa!)
the modprobe ufs ; then try to mount read-only the soalris ufs partitions
dmesg |grep solaris
returns :
 sda4: <solaris: [s0] sda5 [s1] sda6 [s2] sda7 [s3] sda8 [s5] sda9 [s7] sda10 
(You can know which partitions and slices are of solaris by this)


I tried mounting it read-ony with all ufs types,namely:
mount -t ufs -o ro /dev/sda5 /mnt/solaris
mount -t ufs -o ro,ufstype=sunx86 /dev/sda5 /mnt/solaris
mount -t ufs -o ro,ufstype=ufs2   /dev/sda5 /mnt/solaris
....
the error I get is:
mount: wrong fs type, bad option, bad superblock on /dev/sda5,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

what i see in the kernel log while trying to mount is :
ufs_read_super: bad magic number

The same happened with the other solaris slices (/dev/sda6-/dev/sda10).

more important info: 



Steps to Reproduce:
1.described above
2.
3.
  
Actual results:


Expected results:


Additional info:
1) file -s /dev/sda5


/dev/sda5: Unix Fast File system (little-endian), last mounted on /, 
last written at Wed Oct 25 10:30:57 2006, clean flag 253,
number of blocks 20482875, number of data blocks 20172604, number
of cylinder groups 417, block size 8192, fragment size 1024, minimum
percentage of free blocks 1, rotational delay 0ms, disk rotational speed 60rps,
TIME optimization

2) I tried the same with FC6 live cd for i386 (NOT x86_64).
I mean the FC-6-i386-Unity-SERVER-20061024-LiveCD.
There the mount on these ufs same partitions worked ! which 
may indicate that the problem is something which exist ONLY in 
x86_64 FC6 machines.
Comment 1 Dave Jones 2006-10-31 12:13:32 EST

*** This bug has been marked as a duplicate of 209921 ***
Comment 2 Dave Jones 2006-10-31 12:14:12 EST

*** This bug has been marked as a duplicate of 209921 ***
Comment 3 Rami Rosen 2006-11-02 03:26:32 EST
I am not sure at all that it the same bug; in fact,
I applied the patch from Comment #1  in #209921  on Fedora Core 6, x86_64 and
tried to mount 
a solaris ufs filesystem ; It did not work.
As far as I know, the solaris ufs filesystem is of type sunx86 or "old" and
not ufs2 as in BSD; However, I tried all three possibilties after applying that
patch.

Here results I got: 
  
mount: wrong fs type, bad option, bad superblock on /dev/hda3,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

when trying 
mount -t ufs -o ro /dev/hda3 /mnt/sol
mount -t ufs -o ro,ufstype=sunx86 /dev/hda3 /mnt/sol
mount -t ufs -o ro,ufstype=ufs2 /dev/hda3 /mnt/sol

Rami Rosen

Note You need to log in before you can comment on or make changes to this bug.