Bug 212709 - Yumex exits with an unhandled exception error while trying to receive repomd.xml after adding core-source repo
Yumex exits with an unhandled exception error while trying to receive repomd....
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 04:34 EDT by Timo Trinks
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 10:30:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timo Trinks 2006-10-28 04:34:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
Component: yumex
Version: 1.1.7
Summary: TB58bd9c01 yumexBase.py:229:doRepoSetup:RepoError: Cannot open/read repomd.xml file for repository: core-source

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 137, in on_pkgProcess_clicked
    self.on_queueProcess_clicked( widget )
  File "/usr/share/yumex/yumexmain.py", line 184, in on_queueProcess_clicked
    self.yumexbase.reset_ts()
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 124, in reset_ts
    self.doUpdateSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 353, in doUpdateSetup
    self.doRepoSetup()
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 229, in doRepoSetup
    raise Errors.RepoError, ( 'Cannot open/read repomd.xml file for repository: %s' % repo )
RepoError: Cannot open/read repomd.xml file for repository: core-source

Local variables in innermost frame:
e: failure: repodata/repomd.xml from core-source: [Errno 256] No more mirrors to try.
thisrepo: None
repos: [<yum.yumRepo.YumRepository object at 0x8a918ec>, <yum.yumRepo.YumRepository object at 0x8a91f6c>, <yum.yumRepo.YumRepository object at 0x89efb8c>, <yum.yumRepo.YumRepository object at 0x8a917cc>]
repo: core-source
num: 1
self: <yumex.yumexBase.yumexBase object at 0x860acac>


Version-Release number of selected component (if applicable):
yumex-1.1.7-1.0.fc6

How reproducible:
Always


Steps to Reproduce:
1. Run yumex
2. Add core-source repository
3.

Actual Results:
Yumex exits with an unhandled exception error (see above)

Expected Results:
Yumex should've received the file repomd.xml

Additional info:
It appears that the URL Yumex is looking for the file repomd.xml is incorrect:
Yumex looks for http://redhat.download.fedoraproject.org/pub/fedora/linux/core/6/SRPMS/repodata/repomd.xml

<snip>

Trying other mirror.
Preparing for install/remove/update
--> Preparing for install
Loading Repositories Data : Init. core-source repository
Determining fastest mirrors for core-source
--> Mirrors Detected (Top 3)
---> http://redhat.download.fedoraproject.org/pub/fedora/linux/core/6/SRPMS/
Failure getting http://redhat.download.fedoraproject.org/pub/fedora/linux/core/6/SRPMS/repodata/repomd.xml: 
  --> [Errno 14] HTTP Error 404: Date: Sat, 28 Oct 2006 08:05:36 GMT
  --> Server: Apache
  --> Transfer-Encoding: chunked
  --> Content-Type: text/html

</snip>

However, the actual URL appears to be 
http://redhat.download.fedoraproject.org/pub/fedora/linux/core/6/source/SRPMS/repodata/
Comment 1 Tim Lauridsen 2006-10-28 10:17:34 EDT
I will investigate the error
Comment 2 Tim Lauridsen 2006-10-29 02:11:27 EST
Looks like the error also exits in yum

[tim@localhost ~]$ sudo yum --disablerepo=\* --enablerepo=core-source list
Password:
Loading "installonlyn" plugin
Setting up repositories
http://redhat.download.fedoraproject.org/pub/fedora/linux/core/6/SRPMS/repodata/repomd.xml:
[Errno 14] HTTP Error 404: Date: Sun, 29 Oct 2006 06:51:35 GMT
Server: Apache
Transfer-Encoding: chunked
Content-Type: text/html

Trying other mirror.
Error: Cannot open/read repomd.xml file for repository: core-source
Comment 4 Tim Lauridsen 2006-10-29 10:30:40 EST
The Mirrorlist CGI is fixed now.

Note You need to log in before you can comment on or make changes to this bug.