Bug 212737 - Slow boot with message: ata[n]: port is slow to respond, please be patient
Slow boot with message: ata[n]: port is slow to respond, please be patient
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 11:58 EDT by Tom
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version: kernel-2.6.19-1.2895.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 16:10:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom 2006-10-28 11:58:21 EDT
Description of problem:
Slow boot with message:  ata[n]: port is slow to respond, please be patient

Version-Release number of selected component (if applicable):
2.6.18-1.2798.fc6

How reproducible:
Always

Steps to Reproduce:
1. Power on and boot Fedora
2.
3.
  
Actual results:
Very slow boot, followd by messages...

ata1: SATA max UDMA/133 cmd 0xFE00 ctl 0xFE12 bmdma 0xFEA0 irq 177
ata2: SATA max UDMA/133 cmd 0xFE20 ctl 0xFE32 bmdma 0xFEA8 irq 177
scsi0 : ata_piix
usb 2-1: new full speed USB device using uhci_hcd and address 4
usb 2-1: configuration #1 chosen from 1 choice
ata1: port is slow to respond, please be patient
ata1: port failed to respond (30 secs)
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: softreset failed, retrying in 5 secs
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: softreset failed, retrying in 5 secs
ata1: SRST failed (status 0xFF)
ata1: SRST failed (err_mask=0x100)
ata1: reset failed, giving up
scsi1 : ata_piix
ata2: port is slow to respond, please be patient
ata2: port failed to respond (30 secs)
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: softreset failed, retrying in 5 secs
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: softreset failed, retrying in 5 secs
ata2: SRST failed (status 0xFF)
ata2: SRST failed (err_mask=0x100)
ata2: reset failed, giving up

Expected results:
Normal init without delay

Additional info:
I think this is for sure related to kernel 2.6.18 series, also happened with FC5
2.6.18 series.

Dell dimension 8300, P4 3.0GHz HT, dual WDC WD1600JB series HDs, 2GB DDR RAM
Comment 1 Ronno von Ronnerson 2006-10-31 06:47:41 EST
Same problem on a Dell Optiplex 745 , Intel Core2duo + intel chipset 

lspci :
00:00.0 Host bridge: Intel Corporation 82Q963/Q965 Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82Q963/Q965 PCI Express Root Port (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI #2 (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1
(rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HB/HR (ICH8/R) LPC Interface
Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA IDE
Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801H (ICH8 Family) 2 port SATA IDE
Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Unknown device 7183
01:00.1 Display controller: ATI Technologies Inc Unknown device 71a3
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5754 Gigabit
Ethernet PCI Express (rev 02)

# Dmesg output exactly the same, only on this machine at ata 3 and ata 4

# In the BIOS are these two ports disabled (ata3 + ata4), because it looks like
there is no IDE-port build on the mainboard and only use of SATA devices.
Comment 2 Thomas Chung 2006-10-31 16:06:34 EST
I can confirm same message appears during the boot right after installing kernel
2.6.18-1.2200.fc5smp

ata1: port filed to respond
ata1: SRST failed
      ...

Dell Precision 360n, P4 2.80Ghz, HT, 2 IDE drives (40GB and 160GB), 1.5GB RAM

Switching back to older kernel seems OK.
Comment 3 Thomas Chung 2006-11-01 02:09:15 EST
(In reply to comment #2)
> I can confirm same message appears during the boot right after installing kernel
> 2.6.18-1.2200.fc5smp
> 
> ata1: port filed to respond
> ata1: SRST failed
>       ...
> 
> Dell Precision 360n, P4 2.80Ghz, HT, 2 IDE drives (40GB and 160GB), 1.5GB RAM
> 
> Switching back to older kernel seems OK.

I just upgraded the system to FC6 and I'm still getting same message during the
boot with kernel 2.6.18-1.2798.fc6

This is what I see in /var/log/messages

Oct 31 13:07:08 localhost kernel: ata1: port is slow to respond, please be patient
Oct 31 13:07:08 localhost kernel: ata1: port failed to respond (30 secs)
Oct 31 13:07:08 localhost kernel: ata1: SRST failed (status 0xFF)
Oct 31 13:07:08 localhost kernel: ata1: SRST failed (err_mask=0x100)
Oct 31 13:07:08 localhost kernel: ata1: softreset failed, retrying in 5 secs
Oct 31 13:07:08 localhost kernel: ata1: SRST failed (status 0xFF)
Oct 31 13:07:08 localhost kernel: ata1: SRST failed (err_mask=0x100)
Oct 31 13:07:08 localhost kernel: ata1: softreset failed, retrying in 5 secs
Oct 31 13:07:08 localhost kernel: ata1: SRST failed (status 0xFF)
Oct 31 13:07:08 localhost kernel: ata1: SRST failed (err_mask=0x100)
Oct 31 13:07:08 localhost kernel: ata1: reset failed, giving up
Oct 31 13:07:08 localhost kernel: scsi1 : ata_piix
Oct 31 13:07:08 localhost kernel: ata2: port is slow to respond, please be patient
Oct 31 13:07:08 localhost kernel: ata2: port failed to respond (30 secs)
Oct 31 13:07:08 localhost kernel: ata2: SRST failed (status 0xFF)
Oct 31 13:07:08 localhost kernel: ata2: SRST failed (err_mask=0x100)
Oct 31 13:07:08 localhost kernel: ata2: softreset failed, retrying in 5 secs
Oct 31 13:07:08 localhost kernel: ata2: SRST failed (status 0xFF)
Oct 31 13:07:08 localhost kernel: ata2: SRST failed (err_mask=0x100)
Oct 31 13:07:08 localhost kernel: ata2: softreset failed, retrying in 5 secs
Oct 31 13:07:08 localhost kernel: ata2: SRST failed (status 0xFF)
Oct 31 13:07:08 localhost kernel: ata2: SRST failed (err_mask=0x100)
Oct 31 13:07:08 localhost kernel: ata2: reset failed, giving up
Comment 4 Eric McRae 2006-11-28 01:25:58 EST
I also geth these messages with the accompanying long startup delay.  I have no
SATA drives in my system.  I do have two IDE drives.  I do have a SATA
controller according to the bios.
Comment 5 Ronno von Ronnerson 2006-12-21 12:57:05 EST
For the Dell Optiplex 745 I have made a solution.

Thanks to the added (new)libata-core.c and libata.h of member "bseltzer" at
'fedoraforum.org', I have compiled a new kernel, based on the kernel
2.6.18-1.2798.fc6, with success.

http://forums.fedoraforum.org/attachment.php?attachmentid=10182 (libata-core.c)
http://forums.fedoraforum.org/attachment.php?attachmentid=10184 (libata.h)

Just follow the whole process of compiling a new kernel via
http://fedoraproject.org/wiki/Docs/Beats/Kernel?highlight=%28kernel%29

The only difference is :
Add the (new)'libata-core.c' in ~/rpmbuild/BUILD/kernel*/linux*/drivers/scsi
Add the (new)'libata.h' in ~/rpmbuild/BUILD/kernel*/linux*/include/linux

Don't forget to first backup the original libata-core.c and libata.h

Hopefully this is a solution for all the Linux kernel versions.

Thanks 'bseltzer' for this solution.
Comment 6 Will Woods 2007-01-12 13:53:17 EST
For my Dell with an ICH7 SATA controller, this problem is fixed in
kernel-2.6.19-1.2895.fc6. Can you enable the updates-testing repo and try that
kernel?

(yum --enablerepo=updates-testing update kernel should do it)
Comment 7 Thomas Chung 2007-01-12 16:26:07 EST
I'm happy to report kernel-2.6.19-1.2895.fc6 fixed this issue.
I built Fedora LiveCD with this new kernel and tested on my trusted
Dell Linux Workstation with two hard drives (1 SCSI and 1 IDE).

# fdisk -l

Disk /dev/hda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1       30401   244196001   83  Linux

Disk /dev/sda: 73.4 GB, 73407820800 bytes
255 heads, 63 sectors/track, 8924 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14        8670    69537352+  83  Linux
/dev/sda3            8671        8924     2040255   82  Linux swap
Comment 8 Jeroen Janssen 2007-01-15 08:25:08 EST
I'm happy to report that kernel-2.6.19-1.2895.fc6 fixed this issue on my Dell
Optiplex GX270.
Comment 9 Will Woods 2007-01-15 11:47:14 EST
Tom, since you're the original reporter for this bug, can you confirm that
kernel-2.6.19-1.2895.fc6 fixes the issue for you?
Comment 10 Tom 2007-01-15 14:53:54 EST
Will, it would appear that kernel-2.6.19-1.2895.fc6 fixes the issue on my end.
Comment 11 Will Woods 2007-01-15 16:10:10 EST
Excellent. Let's declare this bug closed.

Note You need to log in before you can comment on or make changes to this bug.