Bug 212743 - Error: Missing Dependency: audit-libs = 1.2.9-1.fc7 is needed by package audit-libs-python
Error: Missing Dependency: audit-libs = 1.2.9-1.fc7 is needed by package audi...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: audit (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Grubb
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 12:38 EDT by Dale E. Moore
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 10:13:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"yum list | grep fc7" folks after fc5 to fc6 upgrade (9.25 KB, text/plain)
2006-10-31 12:53 EST, Dale E. Moore
no flags Details

  None (edit)
Description Dale E. Moore 2006-10-28 12:38:06 EDT
Description of problem:
I downloaded FC6 i386 CD and upgraded my FC6 Test 3 then did
[root@BrainIac yum.repos.d]# yum -y update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gaim.i386 2:2.0.0-0.17.beta4.fc6 set to be updated
---> Package tar.i386 2:1.15.1-21.fc6 set to be updated
---> Package audit-libs.i386 0:1.2.9-1.fc6 set to be updated
---> Package pygtk2-libglade.i386 0:2.10.1-5.fc6 set to be updated
---> Package libsepol-devel.i386 0:1.15.1-1.fc6 set to be updated
---> Package xsane-gimp.i386 0:0.991-4.fc6 set to be updated
---> Package pygtk2.i386 0:2.10.1-5.fc6 set to be updated
---> Package xsane.i386 0:0.991-4.fc6 set to be updated
---> Package shadow-utils.i386 2:4.0.17-7.fc6 set to be updated
---> Package bluez-utils.i386 0:3.7-2 set to be updated
---> Package eclipse-changelog.i386 1:2.3.3-2.fc6 set to be updated
---> Package vnc-server.i386 0:4.1.2-5.fc6 set to be updated
---> Package libsepol.i386 0:1.15.1-1.fc6 set to be updated
---> Package pygobject2.i386 0:2.12.2-1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: audit-libs = 1.2.9-1.fc7 for package: audit-libs-python
--> Finished Dependency Resolution
Error: Missing Dependency: audit-libs = 1.2.9-1.fc7 is needed by package
audit-libs-python

Version-Release number of selected component (if applicable):
--> Processing Dependency: audit-libs = 1.2.9-1.fc7 for package: audit-libs-python
Error: Missing Dependency: audit-libs = 1.2.9-1.fc7 is needed by package
audit-libs-python


How reproducible:
# yum update

Steps to Reproduce:
1. upgrade fc6 i386 test 3 with fc6 i386 cd
2. reboot
3. yum update
  
Actual results:
dependency problems.

Expected results:
system updated

Additional info:
I can't think of anything right now.
Comment 1 Steve Grubb 2006-10-28 16:52:11 EDT
Offhand I don't know what could be the problem. If you update just audit-libs,
does it work OK? Just curious if there is a repo sync problem. The python-libs
part of the spec file looks like this:

Requires: %{name}-libs = %{version}-%{release}
Comment 2 Dale E. Moore 2006-10-28 23:59:39 EDT
Updating only audit-libs:
[root@BrainIac yum.repos.d]# yum update audit-libs
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                      100% |=========================| 1.1 kB    00:00     
updates                   100% |=========================| 1.2 kB    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 1.2 MB    00:15     
################################################## 3796/3796
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package audit-libs.i386 0:1.2.9-1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: audit-libs = 1.2.9-1.fc7 for package: audit-libs-python
--> Finished Dependency Resolution
Error: Missing Dependency: audit-libs = 1.2.9-1.fc7 is needed by package
audit-libs-python

I wonder how fc7 got into the mix?
Comment 3 Dale E. Moore 2006-10-30 00:26:31 EST
Hi All,

I don't know what the proper correction to this problem is, but; my work-around is:

[root@BrainIac ~]# yum --exclude audit-libs update

Everything but audit-libs appears to have been updated OK. I still get the
errors from "yum update" but I can live with this until I dig into it a bit
more. Or perhaps some of the other FC5 upgrades I have planned will disclose
other solutions.

Many thanks for lending a sympathetic ear,
Dale E. Moore
Comment 4 Dale E. Moore 2006-10-31 10:13:30 EST
Hi All,

[root@BrainIac ~]# yum -y update

works perfectly now!

Many thanks,
Dale E. Moore
Comment 5 Dale E. Moore 2006-10-31 12:53:14 EST
Created attachment 139878 [details]
"yum list | grep fc7" folks after fc5 to fc6 upgrade

I just wanted y'all to know what packages appear to be fc7 after upgrading an
fc5 system to fc6. FYI!
Comment 6 Dale E. Moore 2006-10-31 13:13:24 EST
Hi All,

Interestingly I had a plan to yum remove fc7-package-x then yum install... So I
tried this with:

[root@BrainIac ~]# yum remove GConf2 a2ps alacarte anacron at at-spi atk
audit-libs-python beagle beagle-gui
...
Remove     323 Package(s)         

but became frightened when it looked like I'd be un-installing everything. Any
other suggestions are much appreciated. (I suppose one strait forward approach
would be to install FC6 deleting all partitions.)

Many thanks for your thoughts,
Dale E. Moore

Note You need to log in before you can comment on or make changes to this bug.