Bug 212758 - Yumex crashes
Yumex crashes
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 15:19 EDT by Leo Wallentin
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 04:29:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leo Wallentin 2006-10-28 15:19:12 EDT
Description of problem:
Yumex sometimes crashes with  a message like this:

------------------------------------------------------------

Component: yumex
Version: 1.1.7-
Summary: TB9f78d0ec main.py:244:execute:DatabaseError: no such column: installtime

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 126, in on_view_cursor_changed
    self.writePkgTime( self.pkgInfo, pkg, 'Install Time : %s\n', "installtime" )
  File "/usr/share/yumex/yumexmain.py", line 955, in writePkgTime
    data = pkg.getAttr( attr )
  File "/usr/lib/python2.4/site-packages/yumgui/packages.py", line 103, in getAttr
    return self._get_availible_attr(attr)
  File "/usr/lib/python2.4/site-packages/yumgui/packages.py", line 111, in
_get_availible_attr
    return self.__pkg.returnSimple(attr)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 68, in
returnSimple
    c.execute(query)
  File "/usr/lib64/python2.4/site-packages/sqlite/main.py", line 244, in execute
    self.rs = self.con.db.execute(SQL)
DatabaseError: no such column: installtime

Local variables in innermost frame:
self: <sqlite.main.Cursor instance at 0xed79638>
parms: ()
SQL: select installtime from packages where pkgId =
'aa1c1f55b1fe3f6ad9be347ce29b7bdad56777a2'



------------------------------------------------------------

This happens sometimes when checking/unchecking items in update/install/remove
lists, otherwise I can see no patterns.
Comment 1 Tim Lauridsen 2006-10-30 12:24:19 EST
I will see if i can reproduce the error
Comment 2 Tim Lauridsen 2006-11-10 04:29:23 EST
Sorry, i cant reproduce this one, it is some weird stuff happening in the SQLite
code used by yum.
  

Note You need to log in before you can comment on or make changes to this bug.