Bug 212780 - /usr/bin/python: free(): invalid pointer: 0x08b84040
/usr/bin/python: free(): invalid pointer: 0x08b84040
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: newt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 21:20 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-06 22:11:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full backtrace (14.48 KB, text/plain)
2006-10-30 14:50 EST, Robert Scheck
no flags Details
another backtrace file (11.69 KB, text/plain)
2006-12-12 21:07 EST, sangu
no flags Details

  None (edit)
Description Robert Scheck 2006-10-28 21:20:06 EDT
Description of problem:
*** glibc detected *** /usr/bin/python: free(): invalid pointer: 0x08b84040 ***
                                                                               
======= Backtrace: =========
                                                                                 
                          /lib/libc.so.6[0x95defd]
                                                                                 
                                                  /lib/libc.so.6(cfree+0x90)
[0x961550]
                        /usr/lib/python2.5/site-packages/_snackmodule.
so[0xdd3846]
                                                                                 
 /usr/lib/libpython2.5.so.1.0[0xcaec02]
                                                                                 
                                       /usr/lib/libpython2.5.so.1.0[0xc896b1]
               /usr/lib/libpython2.5.so.1.0[0xcc4d5d]
                                                     /usr/lib/libpython2.5.so.1.
0[0xca5032]
                                                                                 
          /usr/lib/libpython2.5.so.1.0[0xcaec02]
                                                                                 
                                                /usr/lib/libpython2.5.so.1.
0[0xc896b1]
                        /usr/lib/libpython2.5.so.1.0(PyEval_EvalFrameEx+0x9e0)
[0xcf83a0]
                                                                                 
       /usr/lib/libpython2.5.so.1.0(PyEval_EvalFrameEx+0x63cf)[0xcfdd8f]
          /usr/lib/lAbgebrochen

BTW, "Abgebrochen" means "Canceled".

Version-Release number of selected component (if applicable):
python25-2.5-0

How reproducible:
Running system-config-date in TUI and quitting without any changes.

Actual results:
Invalid pointer.

Expected results:
No invalid pointer... ;-)
Comment 1 Robert Scheck 2006-10-28 21:22:40 EDT
BTW, same at system-config-keyboard in TUI. IMHO either newt/snack or python
is broken.
Comment 2 Jeremy Katz 2006-10-30 13:37:47 EST
Can you run with _MALLOC_CHECK_=2 and get a full backtrace from gdb?
Comment 3 Robert Scheck 2006-10-30 14:50:46 EST
Created attachment 139757 [details]
Full backtrace

Is this what you expected to get by me?
Comment 4 Robert Scheck 2006-10-30 14:53:16 EST
I am providing the requested information for this bug *ticks*
Comment 5 sangu 2006-12-12 20:31:32 EST
this problem still happens in python-2.5-3.fc7.

Starting system-config-display, *** glibc detected *** python2: free(): invalid
pointer: 0x09c81b00 ***  happens.
Comment 6 sangu 2006-12-12 21:07:07 EST
Created attachment 143485 [details]
another backtrace file

pyxf86config-0.3.31-4.fc7
Comment 7 Robert Scheck 2006-12-19 18:06:20 EST
Ping? Nobody interested in fixing this annoying bug?
Comment 8 Jeremy Katz 2006-12-19 20:41:20 EST
Sorry, thought I had reassigned to the right component after looking into it.
Comment 9 Robert Scheck 2006-12-20 05:37:55 EST
Hum? Why is this problem re-asssigned to pyxf86config? Any TUI application 
(system-config-*) seems to be affected. IMHO the problem is somewhere between 
newt and python, isn't it?
Comment 10 Robert Scheck 2007-01-04 16:12:01 EST
Ping?
Comment 11 Michal Jaegermann 2007-01-06 13:08:45 EST
It appears that bug 220923 will be another instance, or closely related,
to this problem (although that appears to start quite a bit later
than a date on the original report from Robert Scheck).

Presumably glibc got stricter in catching those things as I see also
similar bombs which can be likely be traced back to bugs in fontconfig
or Tk (or both playing together?).
Comment 12 Jeremy Katz 2007-01-06 15:29:46 EST
This is being caused by snack allocating memory with PyObject_Malloc and then
freeing it with PyMem_DEL.  In python 2.5, these actually have a differences (so
that the interpreter can return memory to the system).

Fixed in newt-0.52.4-3.fc7
Comment 13 Robert Scheck 2007-01-06 18:41:09 EST
Yepp, your fix is confirmed to work in newt-0.52.4-3. Is there any reason why 
you left open this bug report?
Comment 14 Jeremy Katz 2007-01-06 22:11:43 EST
Forgot to hit the closed button :)

Note You need to log in before you can comment on or make changes to this bug.