Bug 212789 - FC5=>FC6 upgrade replaced sendmail.cf with default stub.
FC5=>FC6 upgrade replaced sendmail.cf with default stub.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 23:12 EDT by John Bass
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 09:36:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Bass 2006-10-28 23:12:45 EDT
Description of problem: Upgrade replaced configured sendmail.cf file with
default stub. Since this leaves most production mail relays crippled, the
default upgrade script should leave production files in place, and install as
.rpmnew


Version-Release number of selected component (if applicable):


How reproducible:
Appears to be always, did both our servers

Steps to Reproduce:
1. upgrade from FC5 to FC6 via CDROM
2.
3.
  
Actual results:
sendmail.cf file has been replaced with default stub, leaving sendmail
effectively disabled as a gateway mail forwarding relay.

Expected results:
new default sendmail.cf files should be installed as sendmail.cf.rpmnew

Additional info:
Comment 1 Thomas Woerner 2007-07-31 09:36:36 EDT
sendmail recreated outdated sendmail.cf on every start. If you are modifying
your configuration, you have to use sendmail.mc and other files from /etc/mail.

Note You need to log in before you can comment on or make changes to this bug.