Bug 212792 - FC5=>FC6 upgrade replaced local.cf with default stub file
FC5=>FC6 upgrade replaced local.cf with default stub file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 23:26 EDT by John Bass
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-19 16:01:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Bass 2006-10-28 23:26:28 EDT
Description of problem: The upgrade process saved the local.cf file, and repaced
with a default stub, removing critical site specific settings to protect from
excessive spam. Unless there are critical version skew problems with file
formats and options, production configuration files should be left in place
during an upgrade/update process ... and the new file installed as .rpmnew.


Version-Release number of selected component (if applicable):


How reproducible:
appears always, did for both of our servers.

Steps to Reproduce:
1.CDROM upgrade from FC5=>FC6
2.
3.
  
Actual results:
spamassassin is cripled by having site specific settings removed.

Expected results:
upgrade should leave existing configuration files untouched, unless there are
compelling changes in file format or options requiring manual intervention after
an upgrade/update.

Additional info:
Comment 1 Warren Togami 2006-12-14 13:54:43 EST
The RPM is designed to never replace the local.cf that has been modified.  Your
problem is not normally reproducible.

Are you sure you didn't do an Install instead of Upgrade?  That might have
screwed it up in this way.
Comment 2 Warren Togami 2007-01-19 16:01:29 EST
No response, unable to reproduce this problem, closing.

Note You need to log in before you can comment on or make changes to this bug.