Bug 212802 - cpuspeed: freq scaling fails on HP/Compaq nc6k-series core duo laptops
cpuspeed: freq scaling fails on HP/Compaq nc6k-series core duo laptops
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: cpuspeed (Show other bugs)
6
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Jarod Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-29 02:10 EST by Tero Hiekkalinna
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 17:33:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmegs output (24.49 KB, text/plain)
2006-10-29 02:10 EST, Tero Hiekkalinna
no flags Details

  None (edit)
Description Tero Hiekkalinna 2006-10-29 02:10:58 EST
Description of problem:

Cpuspeed service didn't start on my HP compaq nc8000 laptop. During init startup
service I get following message:

FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device

Because of this cpu frequency is not sclaed and cpu fan is running all the time

Version-Release number of selected component (if applicable):

cpuspeed-1.2.1-1.40.fc6 and kernel-2.6.18-1.2798.fc6

How reproducible:
Always

Steps to Reproduce:
1. Install FC6
2. Reboot

  
Actual results:
cpuspeed didn't start

Expected results:
cpuspeed is started

Additional info:
Comment 1 Tero Hiekkalinna 2006-10-29 02:10:58 EST
Created attachment 139660 [details]
dmegs output
Comment 2 Manmathan Kumarathurai 2006-10-29 18:33:12 EST
I have same problem on my Dell Inspiron 630m with Intel Pentium M cpu.
Running FC6 with kernel 2.6.18-1.2798.fc6.

some output from dmesg:
CPU: After generic identify, caps: afe9fbff 00100000 00000000 00000000 00000180 
00000000 00000000
CPU: After vendor identify, caps: afe9fbff 00100000 00000000 00000000 00000180 0
0000000 00000000
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 2048K
CPU: After all inits, caps: afe9f3ff 00100000 00000000 00000040 00000180 0000000
0 00000000
CPU0: Intel(R) Pentium(R) M processor 1.73GHz stepping 08
Brought up 1 CPUs
ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3] C4[C3])
ACPI: Processor [CPU0] (supports 8 throttling states)
ACPI Exception (acpi_processor-0681): AE_NOT_FOUND, Processor Device is not pres
ent [20060707]
ACPI: Getting cpuindex for acpiid 0x1
ACPI: Thermal Zone [THM] (53 C)
Comment 3 Peter Trenholme 2006-11-01 20:05:18 EST
Same problem on a Gateway M3 laptop.

From similar Bugzilla reports for older kernel versions it seems that the kernel
may have been compiled with the "cpufreq" option disabled. (Not to likely.)

It is also suggested that the actual error message is generated because there is
no no "cpufreq" leaf in the /proc/ tree. (Sorry, I forget the precise location
mentioned.)

Perhaps "acpi_cpuspeed" should be looking at /proc/acpi/cpu/CPUn/throttling
instead for it information??? (Was the information location was changed in FC6?)
Comment 4 Manmathan Kumarathurai 2006-11-01 20:20:32 EST
It seems that Anaconda wrongly installed a i586 kernel. After I upgraded to a
i686 kernel the problem was solved. Now the cpu scales perfectly :-)

But still I see the message in dmesg:

ACPI Exception (acpi_processor-0681): AE_NOT_FOUND, Processor Device is not pres
ent [20060707]

Comment 5 Nigel Horne 2006-11-11 14:00:56 EST
I have the same problem. FC5 was fine, the "upgrade" to FC6 broke it.

[root@philips etc]# /sbin/service cpuspeed start
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device
[root@philips etc]# dmesg | fgrep acpi
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
Time: acpi_pm clocksource has been installed.
[root@philips etc]#

Comment 6 Nigel Horne 2006-11-11 14:18:25 EST
Looks like this may be fall out from by 211941, but I'm unclear where to find a
"686" kernel.
Comment 7 Mike Bartlett 2006-11-16 15:03:23 EST
I have the i686 kernel.

On my HP compaq nc6320  the cpuspeed/cpufreq is not working.  I have set the
driver to "speedstep-centrino" in /etc/cpuspeed.conf, rebooted and it still does
not work.  The laptop is running a centrino core duo (T2500 2GHz).

I am running:
2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:45:28 EST 2006 i686 i686 i386 GNU/Linux

Here is the cpuinfo:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 14
model name      : Genuine Intel(R) CPU           T2500  @ 2.00GHz
stepping        : 8
cpu MHz         : 1995.214
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc pni monitor vmx
est tm2 xtpr
bogomips        : 3992.88

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 14
model name      : Genuine Intel(R) CPU           T2500  @ 2.00GHz
stepping        : 8
cpu MHz         : 1995.214
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc pni monitor vmx
est tm2 xtpr
bogomips        : 3989.45



Comment 8 Jarod Wilson 2006-12-21 11:12:34 EST
(In reply to comment #6)
> Looks like this may be fall out from by 211941, but I'm unclear where to find a
> "686" kernel.

http://fedoraproject.org/wiki/Bugs/FC6Common


(In reply to comment #7)
> I have the i686 kernel.
> 
> On my HP compaq nc6320  the cpuspeed/cpufreq is not working.  I have set the
> driver to "speedstep-centrino" in /etc/cpuspeed.conf, rebooted and it still does
> not work.  The laptop is running a centrino core duo (T2500 2GHz).
> 
> I am running:
> 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:45:28 EST 2006 i686 i686 i386 GNU/Linux

Just because it says i686 in that output doesn't necessarily mean its the i686
kernel. Double-check per the link above via an rpm query. If you do indeed
really have an i686 kernel installed, we'll have to gather some more info,
because that cpu *should* be supported just fine...
Comment 9 Mike Bartlett 2006-12-21 13:31:04 EST
Background: 
My initial installation had an i586 kernel.  Before adding my comment to this
bug, I had already performed the steps outlined on the FC6Common page to update
to a i686 kernel.

Results from the rpm query:

  kernel-2.6.18-1.2849.fc6.i686
  kernel-2.6.18-1.2868.fc6.i686
  kernel-devel-2.6.18-1.2849.fc6.i686
  kernel-devel-2.6.18-1.2868.fc6.i686
  kernel-headers-2.6.18-1.2868.fc6.i386

Contents of my /etc/cpuspeed.conf file:

VMAJOR=1
VMINOR=1

# uncomment this and set to the name of your CPUFreq module
DRIVER="speedstep-centrino"

# Let background (nice) processes speed up the cpu
OPTS="$OPTS -n"

# Add your favorite options here
#OPTS="$OPTS -s 0 -i 10 -r"

# uncomment and modify this to check the state of the AC adapter
#OPTS="$OPTS -a /proc/acpi/ac_adapter/*/state"

# uncomment and modify this to check the system temperature
#OPTS="$OPTS -t /proc/acpi/thermal_zone/*/temperature 75"


Results from "/sbin/service cpuspeed start":
   FATAL: Module speedstep_centrino not found.

Results from "dmesg | grep acpi":
   ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
   ACPI: LAPIC (acpi_id[0x02] lapic_id[0x01] enabled)
   ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
   ACPI: LAPIC_NMI (acpi_id[0x02] high edge lint[0x1])
   ibm_acpi: ec object not found


Comment 10 Jarod Wilson 2006-12-21 14:05:15 EST
(In reply to comment #9)
> Background: 
> My initial installation had an i586 kernel.  Before adding my comment to this
> bug, I had already performed the steps outlined on the FC6Common page to
> update to a i686 kernel.

Okay, good to know.

> Contents of my /etc/cpuspeed.conf file:
> 
> VMAJOR=1
> VMINOR=1
> 
> # uncomment this and set to the name of your CPUFreq module
> DRIVER="speedstep-centrino"
[...]
> Results from "/sbin/service cpuspeed start":
>    FATAL: Module speedstep_centrino not found.

Yeah, that's expected, the centrino stuff is built-in, not a module. Comment
that line out. The initscript should auto-detect centrino and powernow-k8
systems and automagically do the right thing (which is to load cpufreq-ondemand,
which in turn uses the centrino or powernow-k8 bits).
Comment 11 Mike Bartlett 2006-12-21 14:32:03 EST
I commented out the DRIVER="speedstep-centrino" line in the /etc/cpuspeed.conf
file and rebooted with cpufreq.debug-7.

I am now getting the error message:

FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-1.2868.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device

From the dmesg output:

acpi-cpufreq: acpi_cpufreq_init
acpi-cpufreq: acpi_cpufreq_early_init
cpufreq-core: trying to register driver acpi-cpufreq
cpufreq-core: adding CPU 0
acpi-cpufreq: acpi_cpufreq_cpu_init
cpufreq-core: initialization failed
cpufreq-core: adding CPU 1
acpi-cpufreq: acpi_cpufreq_cpu_init
cpufreq-core: initialization failed
cpufreq-core: no CPU initialized for driver acpi-cpufreq
cpufreq-core: unregistering CPU 0
cpufreq-core: unregistering CPU 1


FYI, the file
/lib/modules/2.6.18-1.2868.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko
does exist.



Comment 12 Jarod Wilson 2006-12-21 15:00:22 EST
Crap. Looks like we're lacking some kernel-level support here. You shouldn't be
seeing acpi-cpufreq get loaded unless
/sys/devices/system/cpu/cpu*/cpufreq/scaling_driver doesn't exist. Can you
verify that this is the case?

Also, out of curiosity, what happens if you try to manually load the
cpufreq-ondemand module?

One more thing... Is there by chance a BIOS update for that machine? I'm pretty
sure I've seen other systems w/that CPU that work fine here, so I'd be inclined
to think the issue could be system board level.
Comment 13 Mike Bartlett 2006-12-21 15:13:01 EST
There is no cpufreg directory in either
/sys/devices/system/cpu/cpu0 or
/sys/devices/system/cpu/cpu1

Contents of /sys/devices/system/cpu/cpu0:

drwxr-xr-x 5 root root    0 Dec 21 03:23 cache
-r-------- 1 root root 4096 Dec 21 11:24 crash_notes
drwxr-xr-x 2 root root    0 Dec 21 11:24 topology

Contents of /sys/devices/system/cpu/cpu1:

drwxr-xr-x 5 root root    0 Dec 21 03:23 cache
-r-------- 1 root root 4096 Dec 21 11:24 crash_notes
-rw------- 1 root root 4096 Dec 21 11:24 online
drwxr-xr-x 2 root root    0 Dec 21 11:24 topology

I didn't receive any errors or other feedback when running "/sbin/modprobe
cpufreq-ondemand".  It also didn't change the contents of the
/sys/devices/system/cpu/cpu* directories.

After running it, "/sbin/service cpuspeed start" still returns the following error:
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-1.2868.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device

I have the latest bios for this machine:  F.09, 14 Sept 2006
Comment 14 Alex deVries 2006-12-30 02:10:53 EST
I have exactly the same problem running kernel-2.6.18-1.2798.fc6 and
kernel-2.6.18-1.2868.fc6 for i686 on a Dell D600.  It worked perfectly in FC5.

My /proc/cpuinfo is:
[root@localhost crypto]# cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 2.10GHz
stepping        : 6
cpu MHz         : 598.080
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 mtrr pge mca cmov pat clflush
dts acpi mmx fxsr sse sse2 ss tm pbe up est tm2
bogomips        : 1196.87

It runs at 600Mhz, even though the max is 2.1Ghz.  Sometimes, it boots into the
fastest, but usually into the slowest speed.

There's never anything in the /sys/devices/system/cpu/cpu0 directory but
crash_notes and topology.
Comment 15 Alex deVries 2007-01-02 11:58:16 EST
Okay, I made a mistake.  I was running the i586 kernel, I'd just checked
incorrectly.  So this is not a problem on a Dell D600.

I suspect this bug can be marked as resolved.
Comment 16 Jarod Wilson 2007-01-02 16:06:23 EST
*** Bug 221070 has been marked as a duplicate of this bug. ***
Comment 17 Joachim Kunze 2007-01-02 17:20:44 EST
As I see the same issues with my T22 described in Bug 221070 I've just checked
what kernel version I'm running with the following result:
#rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n"|grep kernel|sort
kernel-2.6.18-1.2868.fc6.i686
kernel-devel-2.6.18-1.2868.fc6.i686
kernel-doc-2.6.18-1.2868.fc6.noarch
kernel-headers-2.6.18-1.2868.fc6.i386

So unfortunately no wrong kernel running and the BIOS is on the latest version.

#cat /proc/cpuinfo shows:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 10
cpu MHz         : 696.991
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
mmx fxsr sse up
bogomips        : 1394.69

Comment 18 Joachim Kunze 2007-01-03 04:26:51 EST
originally it is a 900 MHz CPU, but after loading the cpufreq-ondemand module
the speed went down to 700 MHz like shown in the last posting above
Comment 19 Jarod Wilson 2007-01-03 15:07:54 EST
(In reply to comment #18)
> originally it is a 900 MHz CPU, but after loading the cpufreq-ondemand module
> the speed went down to 700 MHz like shown in the last posting above

And never scales up? Otherwise, it sounds like its doing the right thing to me...
Comment 20 Jarod Wilson 2007-01-03 16:59:28 EST
(In reply to comment #13)
> There is no cpufreg directory in either
> /sys/devices/system/cpu/cpu0 or
> /sys/devices/system/cpu/cpu1
[...]
> After running it, "/sbin/service cpuspeed start" still returns the following
error:
> FATAL: Error inserting acpi_cpufreq
[...]
> I have the latest bios for this machine:  F.09, 14 Sept 2006

I'm still inclined to think this is a bios issue. There doesn't appear to be
anything cpuspeed is at fault for here, but I suppose it could be something
kernel-level. Its possible a newer or older kernel (i.e. 2.6.19 or 2.6.17) might
behave differently... If you care to try a 2.6.19 kernel, check out davej's
in-progress test kernels at http://people.redhat.com/davej/kernels/Fedora/FC6/
and for 2.6.17, an old FC5 kernel ought to be sufficient for testing purposes.
Otherwise, yell at HP?
Comment 21 Joachim Kunze 2007-01-03 17:40:50 EST
(In reply to comment #19)
> (In reply to comment #18)
> > originally it is a 900 MHz CPU, but after loading the cpufreq-ondemand module
> > the speed went down to 700 MHz like shown in the last posting above
> 
> And never scales up? Otherwise, it sounds like its doing the right thing to me...

I've tested it now twice - It'll never scale up if the cpufreq-ondemand modules
is loaded
Comment 22 Jarod Wilson 2007-01-05 16:19:59 EST
Joachim, what do you have for the contents of the following:

/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_*
/sys/devices/system/cpu/cpu0/cpufreq/cpufreq_*_freq
/sys/devices/system/cpu/cpu0/cpufreq/scaling_*_freq

?
Comment 23 Mario Pascucci 2007-01-10 04:26:36 EST
Same problems on HP nc6400 with T2300 Intel Centrino Duo processor.

After correcting "wrong kernel arch" bug, I done some tests:

1- upgrade kernel to 2.6.19-1.2888.fc6 - NO changes
2- inserting manually cpufreq-ondemand or cpufreq-conservative - NO changes
3- tinker with BIOS, disabling dual core (act as core solo) - NO changes

The only strange things that appears in dmesg are:
....
PCI: BIOS Bug: MCFG area at f8000000 is not E820-reserved
PCI: Not using MMCONFIG.
....
ACPI Exception (pci_link-0180): AE_NOT_FOUND, Evaluating _PRS [20060707]
....
(this appears only with dual core disabled in BIOS)
ACPI Exception (acpi_processor-0681): AE_NOT_FOUND, Processor Device is not pres
ent [20060707]

In /sys/devices/system/cpu/cpuN there isn't any "cpufreq" directory.
Comment 24 Jarod Wilson 2007-01-11 16:13:21 EST
For the core duo folks, I'm definitely thinking buggy bioses/acpi tables, with
only a slight chance its a kernel problem. I finally got my hands on a T2500
core duo machine, and I'm sitting on it typing this entry, complete with
perfectly functioning cpu frequency scaling...

For Joachim... I've seen at least one or two other systems that wind up with the
same values (the lowest speed) in scaling_max_freq and scaling_min_freq. Please
verify their contents. At the very least, there's an easy work-around, but I
think there may be something kernel-level that we need to do to ensure we're
getting the proper values in there.
Comment 25 Joachim Kunze 2007-01-14 12:54:35 EST
Jarod,

in /sys/devices/system/cpu/cpu0 there is no directory cpufreq.

After updating to the latest cpuspeed package cpuspeed-1.2.1-1.46.fc6 the
behaviour has changed. When chosing "automatic" when configuring speedstep in
the BIOS, the cpuspeed stays at the maximum. But still, it doesn't scale down.

Comment 26 Joachim Kunze 2007-01-14 13:45:54 EST
I've tested also 2.6.19-1.2888.fc6 - no changes. Modprobing cpufreq-ondemand and
the speed stays again at 700 MHz without scaling up.
Comment 27 Jarod Wilson 2007-01-15 10:42:38 EST
(In reply to comment #25)
> in /sys/devices/system/cpu/cpu0 there is no directory cpufreq.
> 
> After updating to the latest cpuspeed package cpuspeed-1.2.1-1.46.fc6 the
> behaviour has changed. When chosing "automatic" when configuring speedstep in
> the BIOS, the cpuspeed stays at the maximum. But still, it doesn't scale down.

The lack of a cpufreq directory suggests there simply isn't any frequency
scaling support available with current kernels for whatever reason. Lets reopen
bug 221070... :\
Comment 28 Jarod Wilson 2007-01-15 10:51:24 EST
Given that any similar (centrino/core duo) hardware I've been able to get my
hands on works fine, I'm inclined to close this bug WORKSFORME or CANTFIX. Hrm,
it just registered that both Mike and Mario have HP/Compaq nc6000-series
laptops, I'll ask around a bit and see if I can't find one in the neighborhood...
Comment 29 Jarod Wilson 2007-01-16 17:20:42 EST
Altering bz summary, I think everyone else should be taken care of elsewhere
(either they have it working now, or their problem is being tracked in another
bugzilla ticket).

Anyone w/o an nc6k-series HP/Compaq laptop tracking this bug, please file a new
bug against cpuspeed if you aren't already taken care of after verifying you do
have an i686 kernel ( http://fedoraproject.org/wiki/Bugs/FC6Common ) and have
updated to the latest kernel and cpuspeed.
Comment 30 B.M. 2007-01-26 10:06:02 EST
My cpuspeed (cpuspeed-1.2.1-1.42.fc6) also doesn't work. The powernow-k7 driver 
cannot be loaded. Also there is no cpu-freq driver loadable.

I have a AMD XP 1800+ . Cat /proc/cpuinfo results: 

processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 6
model name      : AMD Athlon(tm) XP 1800+
stepping        : 2
cpu MHz         : 1536.945

After a fresh FC6-install (from the iso-images) this message showed on 
bootup: "WARNING: Error inserting freq_table 
(/lib/modules/2.6.18-1.2798.fc6/kernel/drivers/cpufreq/freq_table.ko): 
Operation not permitted
FATAL: Error inserting acpi_cpufreq 
(/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): 
No such device"
(Ananconda installed the i586 arch, but later i installed a correct kernel via 
yum)

After an update (last was 25.01.2006) it vanished. Now i uncommented 
in /etc/cpuspeed.conf the line DRIVER="powernow-k7".
Then i tried to start cpuspeed manually: "/sbin/service cpuspeed start FATAL: 
Module powernow_k7 not found".

I changed the driver to powernow-k8, which also didn't help: "FATAL: Module 
powernow_k8 not found".

"dmesg |grep powernow" showed: "powernow-k8: Processor cpuid 662 not 
supported". Shouldn't it try to load powernow-k7?

I commented the DRIVER="powernow-k7" line out again, typed "/sbin/service 
cpuspeed start" which doesn't give any output.
But /sbin/service cpuspeed status reveals: cpuspeed was stopped.

"/sbin/modprobe acpi-cpufreq" results in: "FATAL: Error inserting acpi_cpufreq 
(/lib/modules/2.6.19-1.2895.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): 
No such device"

"/sbin/lsmod|grep k7" shows absolutely nothing.

"rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n"|grep kernel|
sort" results in: 

kernel-2.6.18-1.2868.fc6.i686
kernel-2.6.19-1.2895.fc6.i686
kernel-devel-2.6.19-1.2895.fc6.i686
kernel-headers-2.6.19-1.2895.fc6.i386

The directory in /sys/devices/system/cpu/cpu0/ is also empty. Where is it?

Today (26.01.2006) i installed the latest BIOS to my EPOX 8kha+, but cpuspeed 
still doesn't work.

In summary: The same problems as the other ones, but on different processor.
Comment 31 Jarod Wilson 2007-01-26 11:42:11 EST
Re: comment #30: completely different issue here, and NOTABUG. Frequency scaling for K7/Athlon class 
processors is largely non-existent, except with athlon mobile procs and a bios with the necessary freq 
scaling support. You're not going to get any freq scaling on that board/cpu combo, no matter what you 
try, which is why cpuspeed silently exits. (powernow-k7 is built-in, btw)
Comment 32 B.M. 2007-01-27 05:52:31 EST
Sorry, my fault!
dmesg |grep ACPI shows: ACPI: CPU0 (power states: C1[C1] C2[C2]). So i thought 
my processor would be scalable.

Thank you for your effort and help!
Comment 33 Jarod Wilson 2007-01-29 21:12:35 EST
Ah yes, power states are different -- C1 vs. C2, I believe is full-power versus idle-cpu-power state. AMD 
didn't really Get It w/cpu frequency scaling until their 64-bit chips...
Comment 34 Jarod Wilson 2007-01-30 17:33:27 EST
Haven't been able to locate a similar laptop, really don't have any option here
but to close as CANTFIX, blaming this on a faulty BIOS since all other
centrino/core{,2} {solo,duo,quad} systems I can get my hands on work fine.
Comment 35 Mike Bartlett 2007-01-31 16:21:14 EST
Good news.  HP has a new BIOS F.0B which I just installed on my compaq nc6320
and it fixed my problems.
Comment 36 Jarod Wilson 2007-01-31 18:00:30 EST
Excellent! Glad to hear that was indeed the answer.

Note You need to log in before you can comment on or make changes to this bug.