Bug 212862 - RFE: konsolescripts
RFE: konsolescripts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yakuake (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dawid Gajownik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-29 14:47 EST by Chitlesh GOORAH
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.7.5-4.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 17:14:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2006-10-29 14:47:47 EST
Description of problem:

This is a RFE. I haven't tested it myself but I use yakuake all the day.
I think It's worth to consider on fedora's yakuake

see http://www.kde-look.org/content/show.php?content=43873

Yakuake's patch: http://www.kde-look.org/content/download.php?content=43873&id=2


KonsoleScripts is script, which automatically renames konsole tabs to what
command you are running.
Comment 1 Dawid Gajownik 2006-10-30 15:59:24 EST
Proposal packages are available here → http://gajownik.fedorapl.org/yakuake/
I'll give it one week testing period. If nothing breaks I'll push it through the
build system :-)
Comment 2 Chitlesh GOORAH 2006-10-30 17:49:22 EST
Did you try it ? I doesn't seem to be working :(
ps: i have already close the old yakuake
Comment 3 Chitlesh GOORAH 2006-10-30 17:56:07 EST
http://www.kde-look.org/content/show.php?content=43873

* 0.83.0
- added support for _upcoming_ yakuake.
(patch for yakuake-2.7.5 is also on downloads, but I won't provide any support
for installing it. It will be included in upcoming yakuake versions). 

see with upstream, if not we have to wait for a new upstream release
Comment 4 Dawid Gajownik 2006-10-31 04:15:24 EST
(In reply to comment #2)
> Did you try it ? I doesn't seem to be working :(

Works for me :-)

> ps: i have already close the old yakuake

Do you source konsolescript in your ~/.bashrc? I have only added *support* for
konsolescript in yakuake -- you have to install konsolescript on your own.
Comment 5 Chitlesh GOORAH 2006-10-31 04:29:09 EST
Hehehe
I was under a different user. It's working :)
Good Job.

can you tell me how you will do the testing of this
http://gajownik.fedorapl.org/yakuake/yakuake-2.7.5-4.i386.rpm ?

Will you push it to fedora-extras-development ?
I'll blog this, to call for testing.
Comment 6 Dawid Gajownik 2006-10-31 05:25:04 EST
(In reply to comment #5)
> can you tell me how you will do the testing of this
> http://gajownik.fedorapl.org/yakuake/yakuake-2.7.5-4.i386.rpm ?

I will need to check whether something breaks with and especially without
konsolescript.
 
> Will you push it to fedora-extras-development ?

Yes, I did it few minutes ago →
http://buildsys.fedoraproject.org/build-status/job.psp?uid=20612

> I'll blog this, to call for testing.

Thanks!

BTW ppc and x86_64 users will need to recompile SRPM, because I do not have
access to these platforms :/

rpmbuild --rebuild --clean yakuake-2.7.5-4.src.rpm
Comment 7 Chitlesh GOORAH 2006-10-31 05:32:36 EST
Yes, I ve seen it :)

I've called for testing:
http://clunixchit.blogspot.com/2006/10/kde-call-for-testing-yakuakes.html#links
Comment 8 Dawid Gajownik 2006-11-09 17:14:37 EST
Fixed in 2.7.5-4.fc6

> I've called for testing:
> http://clunixchit.blogspot.com/2006/10/kde-call-for-testing-yakuakes.html#links

Thanks! BTW you don't need to set executable bit on if you only source the file ;-)

Note You need to log in before you can comment on or make changes to this bug.