Bug 212866 - 'Fatal Error' message says %s instead of server name
'Fatal Error' message says %s instead of server name
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Corey Welton
:
: 212044 (view as bug list)
Depends On:
Blocks: 216873
  Show dependency treegraph
 
Reported: 2006-10-29 15:31 EST by Beth Nackashi
Modified: 2013-01-10 05:12 EST (History)
2 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 20:50:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Beth Nackashi 2006-10-29 15:31:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060911 Red Hat/1.5.0.7-0.1.el4 Firefox/1.5.0.7

Description of problem:
rhn_register could not contact the RHN server as configured in /etc/sysconfig/rhn/up2date.  The Fatal Error message said:

We can't contact the Red Hat Network Server.
                            
Double check the location provided - is '%s'
correct?
If not, you can correct it and try again.

Version-Release number of selected component (if applicable):
rhn-client-tools-0.2.7-1.el5

How reproducible:
Always


Steps to Reproduce:
1.  Configure a server in /etc/sysconfig/rhn/up2date (serverURL) that is valid but unreachable.  In this case it was:

serverURL=https://test07.rhndev.redhat.com/XMLRPC

2.
3.

Actual Results:


Expected Results:


Additional info:
Comment 2 RHEL Product and Program Management 2006-10-30 11:41:17 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Ken Ganong 2006-10-30 15:48:29 EST
*** Bug 212044 has been marked as a duplicate of this bug. ***
Comment 4 James Slagle 2006-11-27 17:51:04 EST
Committed a fix for this:

[up2date_client]$ svn diff tui.py 
Index: tui.py
===================================================================
--- tui.py      (revision 106460)
+++ tui.py      (working copy)
@@ -64,7 +64,7 @@
     try:
         results = func(*params)
     except up2dateErrors.CommunicationError, e:
-        FatalErrorWindow(screen, HOSTED_CONNECTION_ERROR)
+        FatalErrorWindow(screen, HOSTED_CONNECTION_ERROR % cfg['serverURL'])
     except up2dateErrors.SSLCertificateVerifyFailedError, e:
         FatalErrorWindow(screen, e.errmsg)
     except up2dateErrors.AuthenticationOrAccountCreationError, e:
[up2date_client]$ svn ci tui.py 
Sending        tui.py
Transmitting file data .
Committed revision 106530.
Comment 5 RHEL Product and Program Management 2006-12-22 20:50:11 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.