Bug 212877 - Puplet's notifications are not in French
Summary: Puplet's notifications are not in French
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
: 215172 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-29 21:53 UTC by Thomas Canniot
Modified: 2009-09-21 20:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 18:43:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update popup (50.95 KB, image/png)
2006-11-23 07:07 UTC, Thomas Canniot
no flags Details
Fixes the mentioned issue and marks two other strings for translation (1.06 KB, patch)
2006-11-24 10:50 UTC, Frank Arnold
no flags Details | Diff

Description Thomas Canniot 2006-10-29 21:53:56 UTC
Puplet's norifications are no more in French.

fr.po file of pirut is up to date it seems.

Thanks

Comment 1 Jeremy Katz 2006-10-30 18:45:58 UTC
Which notifications in particular?

From a quick look, everything looks to be appropriately marked

Comment 2 Thomas Canniot 2006-10-30 19:33:57 UTC
At least the one saying that updates are available and the one saying that no
update are downloadable (due to the absence of a connected network).

Comment 3 Jeremy Katz 2006-10-30 20:40:10 UTC
Aha, I see what it is.  Fixed; I'll be pushing an update to FC6 in the next week
or two once I get through the initial flood of FC6 bugs

Comment 4 Thomas Canniot 2006-10-30 20:43:50 UTC
Great news, thanks :)

Comment 5 Fedora Update System 2006-11-06 20:38:07 UTC
pirut-1.2.7-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 6 Fedora Update System 2006-11-10 18:20:52 UTC
pirut-1.2.8-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 7 Jeremy Katz 2006-11-16 04:08:18 UTC
*** Bug 215172 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2006-11-16 23:12:57 UTC
pirut-1.2.8-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 9 Thomas Canniot 2006-11-17 16:50:05 UTC
- Make puplet text be "View Updates..." (#214627)

... is not in French whereas the po is up to date.

Comment 10 Thomas Canniot 2006-11-23 07:07:11 UTC
Created attachment 141970 [details]
update popup

In this update, you can see the untranslated "View updates" button.

There is also an other problem "Security Mises à jour disponibles" (mixing
English and French words) :
 - the word "Security" is not in the pirut .pot file.
 - it seems that pirut is displaying "string 1" + "string 2" ("Security" +
"Updates Available")
But it shouldn't as the "string 1" is not the place where "Security" would be
written in the sentence.  
One string for "Security Updates Available" would fix this.

I can try to explain it again if it is not understandable. Let me know.
Thanks

Comment 11 Frank Arnold 2006-11-24 10:50:07 UTC
Created attachment 142055 [details]
Fixes the mentioned issue and marks two other strings for translation

Inspired from Thomas' Blog I took some time and read through pirut for other
I18N issues. This patch fixes the easy ones, the mentioned concatenation issue
and two user visible but unmarked strings.

However, there are quite some plural handling bugs in pirut/pup/puplet. I will
open another bug report about that.

Comment 12 Jeremy Katz 2006-11-27 21:58:59 UTC
(In reply to comment #10)
> In this update, you can see the untranslated "View updates" button.

Sorry -- timing thing; the build was spun before the update was done.  There's
really no way around this that I know of that doesn't involve either a) holding
off on getting testing/fixes out there or b) not having final translations.
 
> There is also an other problem "Security Mises à jour disponibles" (mixing
> English and French words) :
>  - the word "Security" is not in the pirut .pot file.
>  - it seems that pirut is displaying "string 1" + "string 2" ("Security" +
> "Updates Available")

Bleah, sorry about this.  Thanks for going through and paying so much attention!


(In reply to comment #11)
> Inspired from Thomas' Blog I took some time and read through pirut for other
> I18N issues. This patch fixes the easy ones, the mentioned concatenation issue
> and two user visible but unmarked strings.

Great!  Thanks a lot; applied in CVS

Comment 13 Thomas Canniot 2007-04-28 22:30:44 UTC
Fixed in CVS, yes. This bug can be closed.


Note You need to log in before you can comment on or make changes to this bug.