Bug 21290 - openssh-server-2.3.0p1-4 has wrong path to sftp-server
openssh-server-2.3.0p1-4 has wrong path to sftp-server
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 21295 21883 23574 23697 24203 25037 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-23 18:45 EST by Michal Jaegermann
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-27 10:55:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2000-11-23 18:45:37 EST
'rpm -qlp openssh-server-2.3.0p1-4.i386.rpm' shows
/usr/libexec/openssh/sftp-server
but '/etc/ssh/sshd_config' claims
Subsystem       sftp    /usr/libexec/openssh/openssh/sftp-server

   Michal
   michal@harddata.com
Comment 1 Daniel Roesen 2000-11-27 10:55:14 EST
*** Bug 21295 has been marked as a duplicate of this bug. ***
Comment 2 Nalin Dahyabhai 2000-11-28 18:41:06 EST
Aaargh.  Mid-air collision between the fixpaths script and the
apparently-correct configuration file patch.  Will be fixed in the next Raw Hide
refresh.
Comment 3 Nalin Dahyabhai 2000-11-29 15:22:02 EST
Please verify the fixes in openssh-2.3.0p1-6 in
http://people.redhat.com/nalin/test/ if you have time.  Another bug may turn
this one into a bug-fix errata.
Comment 4 Brent Nordquist 2000-12-04 15:56:26 EST
The -6 RPMs are working fine for me, and fix the problem AFAICS.
Comment 5 Michal Jaegermann 2000-12-04 22:12:04 EST
There is one other minor bug in pty.c.  It tries to include <pty.h>
but there is a file "pty.h" in a source directory and that one is grabbed
instead.  In effect openpty() never gets its prototype.

Short of renaming "pty.h" and editing sources which include that the
following will work:

--- openssh-2.3.0p1/pty.c~	Sun Nov  5 08:31:36 2000
+++ openssh-2.3.0p1/pty.c	Mon Dec  4 20:08:38 2000
@@ -27,7 +27,7 @@
 #endif
 
 #ifdef HAVE_PTY_H
-# include <pty.h>
+# include "/usr/include/pty.h"
 #endif
 #if defined(HAVE_DEV_PTMX) && defined(HAVE_SYS_STROPTS_H)
 # include <sys/stropts.h>

Comment 6 Pekka Savola 2001-01-01 08:25:15 EST
*** Bug 21883 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Roesen 2001-01-10 08:21:39 EST
*** Bug 23574 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Roesen 2001-01-10 08:22:01 EST
*** Bug 23697 has been marked as a duplicate of this bug. ***
Comment 9 Nalin Dahyabhai 2001-01-17 15:04:14 EST
*** Bug 24203 has been marked as a duplicate of this bug. ***
Comment 10 Nalin Dahyabhai 2001-01-26 13:32:27 EST
*** Bug 25037 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.