Bug 212907 - %preuninstall script removes parts of package during upgrade
%preuninstall script removes parts of package during upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-rootpassword (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-29 21:46 EST by Nalin Dahyabhai
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 06:17:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2006-10-29 21:46:07 EST
Description of problem:
The %preun scriptlet for system-config-rootpassword removes all of the package's
.pyc files before it's removed, but it doesn't check that it's the last copy
being removed before doing so, so this happens even if I'm upgrading to a newer
version.
Since we're including the .pyc and .pyo files in the package now, the scriptlet
can probably just be removed.

Version-Release number of selected component (if applicable):
1.1.9-1
Comment 1 Paul Nasrat 2006-10-30 03:20:14 EST
Fixed in cvs will be in next version of s-c-rootpassword.
Comment 2 Paul Nasrat 2006-10-30 06:17:59 EST
1.1.10-1

Note You need to log in before you can comment on or make changes to this bug.