Bug 212910 - %preuninstall script removes parts of package during upgrade
%preuninstall script removes parts of package during upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-httpd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-29 21:54 EST by Nalin Dahyabhai
Modified: 2015-03-04 20:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-20 10:21:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2006-10-29 21:54:28 EST
Description of problem:
The %preun scriptlet for system-config-httpd removes all of the package's
.pyc files before it's removed, but it doesn't check that it's the last copy
being removed before doing so, so this happens even if I'm upgrading to a newer
version.
Since we're including the .pyc and .pyo files in the package now, the scriptlet
can probably just be removed.

Version-Release number of selected component (if applicable):
1.3.3-1.1.1
Comment 1 Phil Knirsch 2006-11-07 09:36:40 EST
Args. Will be fixed in next version. Working on a bigger overhaul atm anyway,
should be out this or next week.

Read ya, Phil
Comment 2 Phil Knirsch 2006-11-20 07:58:13 EST
Last week i've released system-config-httpd-1.4.1 for FC5, FC6 as testing and
put it in FC-devel as well.

Please give it a shot and let me know if this is working for you now.

Thanks,

Read ya, Phil
Comment 3 Nalin Dahyabhai 2006-11-20 10:18:21 EST
It fixes the problem.
Comment 4 Phil Knirsch 2006-11-20 10:21:34 EST
Yar! Closing as Rawhide then. Thanks for checking, Nalin.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.