Bug 212929 - xen-sdlfb is defunct
xen-sdlfb is defunct
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 01:07 EST by Atsushi SAKAI
Modified: 2007-11-16 20:14 EST (History)
4 users (show)

See Also:
Fixed In Version: 5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 10:05:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atsushi SAKAI 2006-10-30 01:07:43 EST
Description of problem:
When I create DomU by setting  sdl=1 in create script,
xen-sdlfb is defunct.

Version-Release number of selected component (if applicable):


How reproducible:
See above

Steps to Reproduce:
1.See above
2.
3.
  
Actual results:
xen-sdlfb is defunct

Expected results:
xen-sdlfb run successfully at DomU boot.

Additional info:

When I try yamahata's patch, this problem still keeps.
So I guess this is not a problem in xc_map_foreign_range.
Comment 1 Daniel Berrange 2006-10-30 07:02:42 EST
Quite likely to be the same issue as in bug  212515  but not confirmed.
Comment 2 Atsushi SAKAI 2006-10-30 19:06:00 EST
I checked it by apply isaku fix.
but the bug still keeps it seems not xc_map_foreign_range problem.
Comment 3 Atsushi SAKAI 2006-12-07 05:29:02 EST
I watch through 2767.el5.
Still remain isaku-fix only(it fixes by driver part).
If this Driver fix still plan to keep, please apply folloiwng patch.
then, RHEL5-IA64 xenfb works. 
this fixes for vmalloc_to_mfn.

diff -urpN drivers.org/xen/xenfb/xenfb.c drivers/xen/xenfb/xenfb.c
--- drivers.org/xen/xenfb/xenfb.c	2006-11-16 15:43:34.000000000 +0900
+++ drivers/xen/xenfb/xenfb.c	2006-11-16 15:46:26.000000000 +0900
@@ -23,6 +23,7 @@
 #include <xen/xenbus.h>
 #include <linux/xenfb.h>
 #include <linux/kthread.h>
+#include <asm/io.h>
 
 #define XENFB_WIDTH 800
 #define XENFB_HEIGHT 600
@@ -368,7 +369,7 @@ static irqreturn_t xenfb_event_handler(i
 
 static unsigned long vmalloc_to_mfn(void *address)
 {
-	return pfn_to_mfn(vmalloc_to_pfn(address));
+	return virt_to_bus(phys_to_virt(vmalloc_to_pfn(address) << PAGE_SHIFT)) >>
PAGE_SHIFT;
 	//return arbitrary_virt_to_machine(address) >> PAGE_SHIFT;
 }
Comment 4 Red Hat Bugzilla 2007-07-24 20:01:33 EDT
change QA contact
Comment 5 Daniel Berrange 2007-09-24 19:36:52 EDT
Mis-categorized - the patch in comment #3 is against the kernel, not userspace,
and is for RHEL-5, rather than Fedora
Comment 6 Chris Lalancette 2007-10-05 09:45:31 EDT
I just tried this out on a 5.1 ia64 guest, and it seems to be doing the right
thing.  Can you confirm that this now works, and close it out if so?

Thanks,
Chris Lalancette
Comment 7 fj-lkml 2007-10-05 09:56:23 EDT
We also confirmed 

Thanks
Atsushi SAKAI
Comment 8 Chris Lalancette 2007-10-05 10:05:25 EDT
OK, thanks.  Closing as CURRENTRELEASE.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.