Bug 213017 - Win + <somekey> (global) shortcuts don't work in KDE
Win + <somekey> (global) shortcuts don't work in KDE
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 11:15 EST by Artem S. Tashkinov
Modified: 2009-05-08 06:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 09:31:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
FC6 install log (4.38 KB, application/octet-stream)
2006-11-28 13:44 EST, Artem S. Tashkinov
no flags Details
xev and .config (9.04 KB, application/octet-stream)
2006-12-13 00:20 EST, Artem S. Tashkinov
no flags Details
some more information (6.32 KB, application/octet-stream)
2006-12-13 00:39 EST, Artem S. Tashkinov
no flags Details
my .config for vanilla kernel 2.6.23 (38.58 KB, text/plain)
2007-10-20 09:49 EDT, Artem S. Tashkinov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 8035 None None None Never
FreeDesktop.org 8815 None None None Never

  None (edit)
Description Artem S. Tashkinov 2006-10-30 11:15:17 EST
Description of problem: Win + <somekey> (global) shortcuts don't work in KDE.


Version-Release number of selected component (if applicable): 3.5.4


How reproducible: Run KDE


Steps to Reproduce:
1. Open Control Center -> Regional and Accessibility -> Keyboard Shortcuts
2. Select Windows Scheme with Win Key -> hit Apply
3. Try to use any global shortcut with Win key
  
Actual results:

Nothing happens, KDE ignores all shortcuts with Win key

Expected results:

Keyboard shortcuts with Win key work.

Additional info: Tested on vanilla install of FC6 with all dependencies
satisfied. These are keyboard related X.org packages installed:
xkeyboard-config
libxkbfile
xorg-x11-xkb-utils

When you try to assign a key combination with Win key to any Action, e.g. <Win>
+ <R> for "Run a Command" then only "R" gets entered.

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver          "kbd"
        Option          "XkbModel"              "pc105"
        Option          "XkbLayout"             "us,ru(winkeys)"
        Option          "XkbOptions"    "grp:alt_shift_toggle,grp_led:scroll"
        Option          "Xleds"                 "1 2 3"
EndSection

No action has been taken on the X.org side, it looks like their bugzilla is
malfunctioning or attracts no attention amongst developers.

This bug is also mentioned here: http://dot.kde.org/1161902851/1162123825/
Comment 1 Artem S. Tashkinov 2006-11-08 01:15:57 EST
Everything was fine with FC5 on this very PC. Can this bug be related to my
keyboard model which is a cheap BTC hardware?
Comment 2 Ngo Than 2006-11-27 15:01:48 EST
strange, i cannot reproduce this problem with current KDE from FC6 update.
<Windows> + R works fine here. Could you please try with a fresh created user?
Please attach the output of "rpm -qa | grep kde". Thanks

Comment 3 Artem S. Tashkinov 2006-11-28 13:44:20 EST
Created attachment 142316 [details]
FC6 install log

Reproducible: always.

Install FC6 the way I've installed it. Read the rest of instructions in the
README file.

:-(
Comment 4 Ngo Than 2006-11-28 13:55:01 EST
Could you please update to new kde-3.5.5 from FC6 update and try again.
If it still does not work, it's something broken with your keyboard.

I have tested several keyboards and did not see the problem!
Comment 5 Artem S. Tashkinov 2006-11-29 09:55:45 EST
Fedora Core 5 *works* fine on this very PC, also when I run FC5 as a guest of
FC6(!) in VMWare then keyboard in the guest works flawlessly.

Ngo, have you tried installing FC6 the way I suggested? From your answer I can
conclude that you haven't.
Comment 6 Ngo Than 2006-11-29 10:02:10 EST
yes, i have installed FC5/FC6/RHEL5 amd tried to reproduce the bug. I cannot 
not reproduce the problem!
Comment 7 Artem S. Tashkinov 2006-12-13 00:20:52 EST
Created attachment 143489 [details]
xev and .config

After some investigation I've understood that my custom kernel is to be blamed
for such a behavior. Somehow it's very strange because with the same kernel
.config-uration FC5 worked fine.

Under two kernels: Fedora Core's one and mine xorg xev application generates
different output.

My kernel configuration is attached. I don't use initrd, some of my /dev
entries were fulfilled in the recovery mode.

I hope it may help to solve my bug.
Comment 8 Artem S. Tashkinov 2006-12-13 00:39:48 EST
Created attachment 143490 [details]
some more information

1) ls -R /dev output
2) lsmod output
3) X.org log
Comment 9 Artem S. Tashkinov 2007-10-20 09:49:37 EDT
Created attachment 233421 [details]
my .config for vanilla kernel 2.6.23

This bug is still here (Fedora 7, KDE 3.5.8 and kernel 2.6.23).
Comment 10 Artem S. Tashkinov 2007-11-16 11:26:40 EST
This bug is now reproducible with the _default_ Fedora 8 packages and all
updates applied.

I'm purely wrathful!
Comment 11 Lukáš Tinkl 2008-01-02 07:38:13 EST
Works perfectly for me under F8, even with russian keyboard
Comment 12 Artem S. Tashkinov 2008-01-10 09:28:02 EST
I can reproduce this bug right now (*all* F8 updates installed):

uname -a
Linux localhost.localdomain 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:59 EST 2007 
i686 athlon i386 GNU/Linux

This is my xorg.conf keyboard section:

Section "InputDevice"
        Identifier      "Keyboard0"
        Driver          "kbd"
        Option          "XkbModel"              "pc104"
        Option          "XkbLayout"             "us,ru"
        
Option          "XkbOptions"            "grp:alt_shift_toggle,grp_led:scroll"
        Option          "Xleds"                 "1 2 3"
        Option          "XkbVariant"            ",winkeys"
EndSection
Comment 13 Artem S. Tashkinov 2008-01-10 09:31:13 EST
Sorry, that's been a false alarm. Everything indeed works. :'-( But with the 
vanilla kernel I still can reproduce this bug.
Comment 14 Artem S. Tashkinov 2009-05-08 06:06:51 EDT
In Fedora 10 I cannot reproduce this bug any longer.

Note You need to log in before you can comment on or make changes to this bug.