Bug 213019 - luci cluster creation gui - usability/accessibility problem with tab sequence
luci cluster creation gui - usability/accessibility problem with tab sequence
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ryan McCabe
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 11:25 EST by Len DiMaggio
Modified: 2009-04-16 18:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 18:18:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The tab order is displayed the numbered text - note how the 2nd set of text fields (hostname/password) is actually accessed last. (159.03 KB, image/jpeg)
2006-10-30 11:25 EST, Len DiMaggio
no flags Details

  None (edit)
Description Len DiMaggio 2006-10-30 11:25:42 EST
Description of problem:
luci cluster creation gui - usability/accessibility problem with tab sequence -
the order does not match the sequence displayed - due to how tables are used in
Javascript. This may cause usability complaints and accessibility issues.

Version-Release number of selected component (if applicable):
luci-0.8-21.el5 (RHEL5-Server-20061027.0)

How reproducible:
100%

Steps to Reproduce:
1. In the 'add a cluster' form, tabbing between text, checkbox, and radio
buttons is not in same orcer (top-down) that the fields are displayed. 
  
Actual results:
The order is confusing.

Expected results:
If a user tabs between fields, the tabbing should follow the logical order
displayed.

Additional info:

See the attachment for an illustration. The numbers to the right of the elipses
show the sequence in which the user moves through the form. When I first saw
this - it took me a moment to realize what happened and to find the currently
active field.
Comment 1 Len DiMaggio 2006-10-30 11:25:42 EST
Created attachment 139726 [details]
The tab order is displayed the numbered text - note how the 2nd set of text fields (hostname/password) is actually accessed last.
Comment 2 Len DiMaggio 2006-10-31 11:13:56 EST
FYI - notes on usability heuristics provided by duffy@redhat.com:

http://intranet.corp.redhat.com/ic/intranet/RedHatSoftwareDesign.html
Comment 3 Ryan McCabe 2006-10-31 16:17:08 EST
thanks for the link. i'll try to incorporate the suggestions, but i'm not sure
it's possible before GA.
Comment 4 Ryan McCabe 2006-12-11 18:18:14 EST
I looked at this a little bit today, and it turns out the problem is with the
XHTML spec and browser implementation. The spec tells you to use the order
<thead><tfoot><tbody>, but the browser (I think all of them) computes the tab
indices top-down, in the order it parses the input.

At this point, I don't want to go mucking around with that stuff, trying to work
around the browser/spec bug and risk breaking deploy/manager cluster functionality.

Note You need to log in before you can comment on or make changes to this bug.