Bug 213041 - find-lang.sh not recognize --all-name option
find-lang.sh not recognize --all-name option
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 12:38 EST by Eric Tanguy
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 14:39:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Tanguy 2006-10-30 12:38:19 EST
Description of problem: 
%find_lang %{name} --all-name which is translated
to /usr/lib/rpm/redhat/find-lang.sh %{buildroot} %{name} --all-name but
during the build process i obtain this error message : 
+ /usr/lib/rpm/redhat/find-lang.sh /var/tmp/ruby-gettext-1.0.0-2.rcn.FC6-root
ruby-gettext --all-name
grep: unrecognized option `--all-name'

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:

error

Expected results:


Additional info:
Comment 1 Ville Skyttä 2006-10-30 16:39:42 EST
The issue here is that find-lang.sh in redhat-rpm-config (/usr/lib/rpm/redhat)
appears to be older than the one in rpm-build (/usr/lib/rpm).
Comment 2 Eric Tanguy 2007-01-05 07:13:32 EST
This bug seems to be simple to resolve! Why there is nothing done ??
Comment 3 Eric Tanguy 2007-04-12 13:14:23 EDT
Up ?
Comment 4 Jeremy Katz 2007-06-19 14:39:34 EDT
Changed to use the copy from rpm in the next version of redhat-rpm-config
Comment 5 Tim Waugh 2007-07-04 12:01:08 EDT
This has broken the coreutils build: see bug #246729.

The LC_TIME locale files are not found, but the LC_MESSAGES locale files are.

Note You need to log in before you can comment on or make changes to this bug.