Bug 213070 - Implement autotools build system for AdminUtil
Implement autotools build system for AdminUtil
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
1.0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316
  Show dependency treegraph
 
Reported: 2006-10-30 13:49 EST by Nathan Kinder
Modified: 2015-12-07 12:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:02:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New Automake Makefile (3.02 KB, text/plain)
2006-10-30 13:49 EST, Nathan Kinder
no flags Details
New Autoconf configure template (2.62 KB, text/plain)
2006-10-30 13:50 EST, Nathan Kinder
no flags Details
New autogen.sh script (1.85 KB, text/plain)
2006-10-30 13:53 EST, Nathan Kinder
no flags Details
ICU m4 file (2.61 KB, text/plain)
2006-10-30 13:54 EST, Nathan Kinder
no flags Details
Mozldap m4 file (3.43 KB, text/plain)
2006-10-30 13:56 EST, Nathan Kinder
no flags Details
NSPR m4 file (2.85 KB, text/plain)
2006-10-30 13:59 EST, Nathan Kinder
no flags Details
NSS m4 file (2.80 KB, text/plain)
2006-10-30 14:00 EST, Nathan Kinder
no flags Details
Cyrus-SASL m4 file (2.89 KB, text/plain)
2006-10-30 14:00 EST, Nathan Kinder
no flags Details
New genrb wrapper template (1.21 KB, text/plain)
2006-10-30 14:03 EST, Nathan Kinder
no flags Details
CVS Diffs (2.00 KB, patch)
2006-10-30 14:06 EST, Nathan Kinder
no flags Details | Diff
CVS Commit Message (3.14 KB, text/plain)
2006-10-30 14:35 EST, Nathan Kinder
no flags Details
CVS Commit for removed files (2.77 KB, text/plain)
2006-10-30 17:48 EST, Nathan Kinder
no flags Details

  None (edit)
Description Nathan Kinder 2006-10-30 13:49:04 EST
A new autotools (namely Autoconf and Automake) based build-system should be
implemented for AdminUtil.  This will make it much easier for people to build
AdminUtil as well as making creation a a buildable source rpm easy.

I will be making a number of attachments to this bug for the new build-system. 
I will not be attaching generated files (such as configure).
Comment 1 Nathan Kinder 2006-10-30 13:49:04 EST
Created attachment 139741 [details]
New Automake Makefile
Comment 2 Nathan Kinder 2006-10-30 13:50:45 EST
Created attachment 139742 [details]
New Autoconf configure template
Comment 3 Nathan Kinder 2006-10-30 13:53:41 EST
Created attachment 139743 [details]
New autogen.sh script

This script will be used to generate new build files (configure, Makefile.in,
etc).  It will ensure that the minimum required versions of the build tools are
used to create any generated build files.
Comment 4 Nathan Kinder 2006-10-30 13:54:45 EST
Created attachment 139744 [details]
ICU m4 file
Comment 5 Nathan Kinder 2006-10-30 13:56:01 EST
Created attachment 139746 [details]
Mozldap m4 file
Comment 6 Nathan Kinder 2006-10-30 13:59:59 EST
Created attachment 139748 [details]
NSPR m4 file
Comment 7 Nathan Kinder 2006-10-30 14:00:22 EST
Created attachment 139749 [details]
NSS m4 file
Comment 8 Nathan Kinder 2006-10-30 14:00:50 EST
Created attachment 139750 [details]
Cyrus-SASL m4 file
Comment 9 Nathan Kinder 2006-10-30 14:03:16 EST
Created attachment 139751 [details]
New genrb wrapper template

This is a new wrapper script template for running ICU's genrb utility. 
Configure will substitute the proper path and library settings to run genrb
during the build.
Comment 10 Nathan Kinder 2006-10-30 14:06:15 EST
Created attachment 139753 [details]
CVS Diffs

The following changes are needed for the new build-system to work properly:

- buildnum.pl needs to be able to simply return the generated build number
instead of storing it in a file.

- The new build-system will set the build number as a define option to the
compiler instead of writing it out into version.h.
Comment 11 Rich Megginson 2006-10-30 14:10:48 EST
Ok.
Comment 12 Nathan Kinder 2006-10-30 14:35:08 EST
Created attachment 139755 [details]
CVS Commit Message

Checked into adminutil (HEAD).	Thanks for the review Rich!
Comment 13 Nathan Kinder 2006-10-30 14:45:40 EST
Now that the new build-system is checked in, I'd like to remove the old
Makefiles and associated build files since we will not be using them anymore. 
Here is the list of files that I'd like to remove:

adminutil/buildpaths.mk
adminutil/components.mk
adminutil/component_versions.mk
adminutil/internal_buildpaths.mk
adminutil/internal_comp_deps.mk
adminutil/Makefile
adminutil/nsarch
adminutil/nsarch.bat
adminutil/nsconfig.mk
adminutil/nscore.mk
adminutil/nsdefs.mk
adminutil/nsftp.sh
adminutil/nsperl.mk
adminutil/ntbomb.pl
adminutil/pkgadminutil.mk
adminutil/pumpkin.pl
adminutil/include/Makefile
adminutil/lib/libadminutil/genrb_wrapper.sh
adminutil/lib/libadminutil/Makefile
adminutil/lib/libadmsslutil/Makefile
adminutil/tests/Makefile
Comment 14 Noriko Hosoi 2006-10-30 14:49:05 EST
(In reply to comment #13)
> Now that the new build-system is checked in, I'd like to remove the old
> Makefiles and associated build files since we will not be using them anymore. 

Looks good!


Comment 15 Nathan Kinder 2006-10-30 17:48:35 EST
Created attachment 139780 [details]
CVS Commit for removed files

Thanks for the review Noriko!  I've removed the old build-system files from
adminutil (HEAD).
Comment 16 Nathan Kinder 2007-12-21 13:44:32 EST
We've been usng the autotoosl based  build-system for adminutil for some time
now with no problems.  The old Makefiles are gone from the source tree as well.

Marking as VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.