Bug 213132 - first boot into a filesytem with TEMPORARY_STATE=y fails in spectacular ways
first boot into a filesytem with TEMPORARY_STATE=y fails in spectacular ways
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 16:51 EST by Christopher Blizzard
Modified: 2014-03-16 23:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 15:13:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christopher Blizzard 2006-10-30 16:51:35 EST
Description of problem:

When setting TEMPORARY_STATE=y in /etc/sysconfig/readonly-root with READONLY=no
on first boot you get some failures to mount various parts of the filesystem.

Version-Release number of selected component (if applicable):

initscripts-8.45.3-1

How reproducible:

Only on first boot with a fresh filesystem.

Steps to Reproduce:
1. Download an OLPC image
2. Burn that image to a USB key or drive 
3. Mount the drive and change the readonly-root config file to add the y
4. Boot in qemu and enjoy!
  
Actual results:

You get error messages such as:

Setting hostname localhost.localdomain [ OK ]
raidautorun: failed to open /dev/md0: No such device or address
can't create lock file /etc/mtab~1244: Read-only file system (use -n flag to
override)
mkdir: cannot create directory '/var/lib/stateless/writable/var': Read-only
filesystem
mount: special device /var/lib/stateless/writable/var/lock does not exist
...

Expected results:

No errors!  It must be perfect!

Additional info:

Some possible things that might be going on:

1. Very often the filesystem might be mounted as read only the first time around
due to it being dirty
2. I suspect that this might be a missing -n on a mount somewhere - probably
when first mounting /var/lib/stateless/writable?
Comment 1 Bill Nottingham 2006-10-30 21:05:22 EST
Fixed in CVS.
Comment 3 Fedora Update System 2006-10-30 22:14:42 EST
initscripts-8.45.4-1 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Fedora Update System 2006-11-06 14:55:14 EST
initscripts-8.45.5-1 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.