Bug 213163 - control-center crashes if "Keyboard Indicator" applet is available
Summary: control-center crashes if "Keyboard Indicator" applet is available
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: David Lawrence
URL:
Whiteboard:
: 213969 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-31 00:27 UTC by petrosyan
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version: libxklavier-3.0-2.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-09 19:38:11 UTC


Attachments (Terms of Use)
bug-buddy bugreport (6.76 KB, text/plain)
2006-10-31 00:28 UTC, petrosyan
no flags Details
strace report about pup problem (50.91 KB, text/plain)
2006-11-06 20:05 UTC, The Source
no flags Details

Description petrosyan 2006-10-31 00:27:26 UTC
Description of problem:
If "Keyboard Indicator" applet is available on the panel, and more than 1
keyboard layout is selected, /usr/libexec/gnome-settings-daemon crashes.
attaching the backtrace.

Version-Release number of selected component (if applicable):
control-center-2.16.0-9.fc6

How reproducible:
Always

Steps to Reproduce:
1. Add "Keyboard Indicator" applet to the panel
2. Add another layout (e.g. "Armenian Phonetic") to the main U.S. one
  
Actual results:
gnome-settings-daemon crashes

Expected results:
shouldn't crash

Comment 1 petrosyan 2006-10-31 00:28:38 UTC
Created attachment 139787 [details]
bug-buddy bugreport

Comment 2 Miroslav Pragl 2006-11-03 11:50:16 UTC
Reproduced on two brand new FC6 installations (both Intel P4 machines,one
desktop with Ati Radeon, second notebook with i8xx integrated graphics.

Another side effect - I can't use ctrl-alt-f1 to switch between TTYs and
XServes. NOt sure though if it relates to keyboard inicator - please comment so
that I know if to open another bugreport.

Comment 3 Radek Vokal 2006-11-03 12:43:29 UTC
It even breaks compiz keyboard shortcuts .. 

Comment 4 petrosyan 2006-11-03 13:31:29 UTC
ctrl-alt-f1 works fine for me. But i disabled the keyboard indicator.

Comment 5 Ray Strode [halfline] 2006-11-03 19:07:11 UTC
Miroslav,

do you have xkeyboard-config installed?  If not, that could explain why
ctrl-alt-f1 doesn't work

Comment 6 Jan Kratochvil 2006-11-03 19:13:50 UTC
Ray,
please check if this Bug is really just a DUPE of Bug 206898, I believe so.


Comment 7 Miroslav Pragl 2006-11-04 09:11:48 UTC
Sorry to confuse you, I mentioned that these bugs COULD be related as they 
started somehow together (crashing keyboard indicator and being unable to use 
ctrl-alt-f1 to switch between consoles). Unfurtunately disabling keyboard 
indicator didn't r-enable console switching.



Comment 8 Matthias Clasen 2006-11-04 18:30:10 UTC
Ray, see http://bugzilla.gnome.org/show_bug.cgi?id=370038
for another libxlavier crash fix

Comment 9 Stephanos Manos 2006-11-04 20:14:08 UTC
For me downgrading libxml2 from 2.6.27-1.FC6 to 2.6.26-2.1.1 fixed the problem
wiht keyboard indicator and fixed the way a couple other applets behaved (and
the desktop generaly).

Should i fill a bug against libxml2?




Comment 10 Matthias Clasen 2006-11-06 01:56:22 UTC
*** Bug 213969 has been marked as a duplicate of this bug. ***

Comment 11 Stephanos Manos 2006-11-06 17:36:38 UTC
Updating libxklavirer as mentioned in BZ#213557 (and libxml2 that i have
downgraded comment #9) fixed the problem




Comment 12 The Source 2006-11-06 20:05:07 UTC
Created attachment 140503 [details]
strace report about pup problem

Comment 13 The Source 2006-11-06 20:07:16 UTC
I tried to install updates and something strange happened.
First puplet said thet 7 updates are available, but when I pressed apply
updates, pup started and said that some other process is accessing package
information. (Perhaps this should be reported as a separate bug).
The when I stopped puplet (and acctually had to stop yum-updatesd to remove
conflict) and launched pup, it hanged. Attaching strace report about this.
Finally when I restarted system (otherwise pup refused to do anything) and
launched pup successfully, it said that no updates are available!!! Where are 7
ones that were available before this?!

Comment 14 The Source 2006-11-08 16:36:10 UTC
Downgraded libxml2 (along with libxslt). Problem dissapeared. So it is in one of
those libraries I guess (libxml2 or libxslt)

Comment 15 petrosyan 2006-11-09 19:38:11 UTC
this bug has been fixed after applying the latest updates

Comment 16 The Source 2006-11-10 06:21:25 UTC
Hey, what do you mean fixed?! Latest libxklavier is not enough to remove the
bug. Downgrading libxml2 and libxslt is also required. So the problem still here

Comment 17 petrosyan 2006-11-10 06:38:55 UTC
I am using libxml2-2.6.27-1.FC6 and libxslt-1.1.18-1.FC6 and the applet is
working just fine. I didn't downgrade anything. Are you sure that your applet
crashes with  updated libxml2 and libxslt packages? If it still crashes, then
open a new bug, because I can't reproduce that behavior.

Comment 18 The Source 2006-11-10 06:55:58 UTC
Hey, you were right! Hmmm... but I was sure I had latest libxklavier when I
encountered this bug.. Well anyway, it works fine now.


Note You need to log in before you can comment on or make changes to this bug.