Bug 213167 - Should /etc/rc.sysinit delete /var/lib/ldap/*/__db.*?
Should /etc/rc.sysinit delete /var/lib/ldap/*/__db.*?
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openldap (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 20:10 EST by Aleksey Nogin
Modified: 2015-01-07 19:14 EST (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2007-0739
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:04:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2006-10-30 20:10:35 EST
We just had a problem, where slapd did not start up properly after machine was
rebooted. It just kept waiting forever in futex call (according to strace).
Deleting /var/lib/ldap/*/__db.* solved the problem.

I am wondering - should may be /etc/rc.sysinit delete /var/lib/ldap/*/__db.* the
same way it currently deletes /var/lib/rpm/__db*?

P.S. Potentially related - bug 195920.
Comment 1 Bill Nottingham 2006-10-30 21:03:35 EST
slapd has its own initscript; ergo this seems more appropriate to do it there?
Comment 2 Aleksey Nogin 2006-10-30 23:34:02 EST
(In reply to comment #1)
> slapd has its own initscript; ergo this seems more appropriate to do it there?

When slapd is being started, there is no way to know for sure whether something
else is currently accessing the DB. I might be wrong, but my guess is that this
is exactly the reason why it is done in rc.sysinit for the rpm DB.

To be honest, I have no idea whether this would be the right thing to do for
slapd, may be there is a reason why RPM DB is special... But there definitely
needs to be something (and bug 195920 suggests that this something may be to
have the ldap startup script to do a DB recovery when necessary).
Comment 3 RHEL Product and Program Management 2007-06-19 04:15:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2007-11-15 11:04:14 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0739.html

Note You need to log in before you can comment on or make changes to this bug.