Bug 213168 - Kudzu does not detect xen paravirt framebuffer, so does not setup fallback serial console on /dev/xvc0
Kudzu does not detect xen paravirt framebuffer, so does not setup fallback se...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
5
All Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 20:17 EST by Daniel Berrange
Modified: 2014-03-16 23:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: kudzu-1.2.34.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-15 16:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2006-10-30 20:17:41 EST
Description of problem:
The recent errata kernel to FC5 added support for the Xen paravirtual
framebuffer driver. Previously the default console that mingetty login prompt
was started on was the serial console (/dev/xvc0), so no special handling was
required. When the framebuffer driver now in the kernel by default, the serial
console no longer gets a mingetty process setup on it - they're attached to the
framebuffer instead.

So, when upgrading, user's existing login console for their guests simply
'disappear', unless they know to use VNC to connect to the framebuffer instead.

Newer kudzu from FC6 will auto-detect the paravirt fb from xen and add an entry
into /etc/inittab to spawn agetty on /dev/xvc0. We need a new kudzu release to
push this same capability to FC5 users.

Version-Release number of selected component (if applicable):
kudzu-1.2.34.4-1
kernel-xenU-2.6.18-1.2200.fc5
xen-3.0.3-1.fc5

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to latest kernel-xenU in a guest
2. Reboot guest
3. Run 'xm console foo'
  
Actual results:
No login prompt

Expected results:
Standard console login prompt

Additional info:
Comment 2 Daniel Berrange 2006-10-31 11:42:17 EST
I installed  1.2.34.5-1  in the guest, rebooted & it correctly updated the
inittab & I got a login prompt, so this looks like a good patch to push for
updates-testing
Comment 3 Fedora Update System 2006-10-31 14:56:11 EST
kudzu-1.2.34.5-1 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Fedora Update System 2006-11-03 11:29:11 EST
kudzu-1.2.34.5-1 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.