Bug 213174 - System hangs when shuting down (or rebooting)
System hangs when shuting down (or rebooting)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 20:43 EST by Greg Huber
Modified: 2007-12-31 14:26 EST (History)
4 users (show)

See Also:
Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 14:26:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Huber 2006-10-30 20:43:10 EST
Description of problem:
After selecting System->Shut Down Gnome appears to die, but
the window manager appears to stay up and the system appears
to go into some sort of infinite loop. The messages file only
shows a time gap when this occures. The system does not respond
to network requests.
The only way to shut the system off is to crash it.


Version-Release number of selected component (if applicable):
FC6 x86_64 - fresh install / fully updated.


How reproducible:
Happens every time


Steps to Reproduce:
1. select System->Shut Down
2.enter halt -p or poweroff
3.
  
Actual results:
The display drops all foreground objects and displays only the background.
There is some brief disk activity every few seconds


Expected results:
The system should proceed through its shut down process.


Additional info:
This is a tough one as the system is not giving me any
hints as to what is hanging.
Comment 1 Milan Kerslager 2006-10-31 07:51:40 EST
Try to press CTRL+ALT+F1 to switch to text console. Then login as root (enter
root as login name and then your root's password) and type: poweroff
Watch what happens. There may be a problem with ACPI poweroff so all services
may go down but the machine itself is not powered off at the very end of the
process.

Problem with auto-switching to text console may be related to the graphics
driver of your video card (ie X.org driver).
Comment 2 Greg Huber 2006-11-01 13:12:15 EST
This also causes the system to hang. I have this same problem
on both an x86_64 and i386 installs now. I had filed another bug
on not being able to switch to a text console, but it's looking
like the problem is with the X server shutting down in both cases.

Both machines are using ATI cards, the x86_64 machine has to use
the ATI 'fglrx' driver because the native 'radeon' driver won't support
1920x1200 displays, the i386 system is using the native 'radeon' driver.
Comment 3 Milan Kerslager 2006-11-01 16:26:16 EST
Try to boot to text mode. This means break countdown of the Grub loader when
machine starts by pressing a key. Then press 'a' (append) and append number 3 to
the very end of kernel line. Then press Enter to boot the system. After the
system boots, login as root and try to poweroff machine. This will show if your
problem is in X server or in the shutdown process.
Comment 4 Greg Huber 2006-11-02 08:54:35 EST
Booted system single user (3), logged in as root and executed 'poweroff'
The system shut down nice and cleanly.
Comment 5 Milan Kerslager 2006-11-02 09:32:30 EST
I'm suggesting to close this bug as NOTABUG as this is the X.org driver bug.
Comment 6 Zhu Wang 2006-11-18 21:28:01 EST
I have a slightly different problem on a HP Omnibook XE3 after I upgraded from
FC-4 to FC-6. When I selected "logout"-> "Turnoff computer", the system would
hang there after the following messages:

...
Halting system...
md: stopping all md devices
shutdown: hda
system halted

I have disabled acpi but it doesn't help. Also I tried to follow the steps
mentioned above, namely, to boot the system single user (3), logged in as root
and executed "poweroff", the same problem. I had to shut the power button to
poweroff.

Reproducible: every time after I upgraded to FC-6, but not when I used all
previous version of red-hat, FC versions.

Comment 7 Jon Stanley 2007-12-31 01:48:14 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 8 Greg Huber 2007-12-31 14:21:36 EST
I am not currently in a position where I can switch to Fedora 8.
I have tried to reproduce this with the latest Fedora 7 kernel
and updates and was not able to. It appears that everything is
working once again.

Thank You.

Comment 9 Jon Stanley 2007-12-31 14:26:56 EST
In that case, I'll close this one as CURRENTRELEASE.  Feel free to reopen if the
problem recurs.

Note You need to log in before you can comment on or make changes to this bug.