Bug 213212 - ftpfs doesn't work with patch mc-ipv6.patch
ftpfs doesn't work with patch mc-ipv6.patch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks: 217510
  Show dependency treegraph
 
Reported: 2006-10-31 04:54 EST by Mykola Ulianytskyi
Modified: 2013-07-02 19:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-23 04:44:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mykola Ulianytskyi 2006-10-31 04:54:32 EST
Description of problem:
  ftpfs: could not setup passive mode

Version-Release number of selected component (if applicable):
   4.6.1a-30.fc6

How reproducible:
  IPv6 is off
  cd ftp://ftp.mydomain.com

Resolution:
  Rebuild with no patch mc-ipv6.patch
Comment 1 Jindrich Novy 2006-11-01 04:58:05 EST
Could you please test:
http://people.redhat.com/jnovy/files/mc-4.6.1a-33.fc7.src.rpm
?

The problem you noticed should be fixed by this release.
Comment 2 Mykola Ulianytskyi 2006-11-01 05:42:56 EST
mc-4.6.1a-33.fc7.src.rpm don't resolve the problem.
Comment 3 Jindrich Novy 2006-11-01 06:44:46 EST
strange, works for me with  mc-4.6.1a-33.fc7

after cd ftp://ftp.gnu.org/

I see the FTP contents without problems with IPv4.
Comment 4 Leonard den Ottolander 2006-11-02 16:01:28 EST
Hi Jindrich,

Are you using passive mode? (I've not tested any of this, but the original
report speaks of passive mode.)
Comment 5 Leonard den Ottolander 2006-11-02 16:24:57 EST
Ok. I did test. Rebuild -33 on FC4 (with mcslang but that is irrelevant here),
no problem with ftp. (Passive is default.) I suppose Nikolay should test again.
Comment 6 Leonard den Ottolander 2006-11-02 16:28:59 EST
Nikolay, if the problem *does* persist for you please run mc with -l and attach
the ftp log file.
Comment 7 Adam Pribyl 2006-11-07 03:31:01 EST
I am having same problem. I simply rpmbuild --rebuild and installed (rpm -U) the
mc-4.6.1a-33 but problem persist. I am behind NAT. The log file does not shows
anything strange, but mc is stalled and shows nothing except message that 
ftpfs: could not setup passive mode
after a while it says something that it tries 
Reading FTP directory ... (strict rfc959)(chdir first)
and finaly dies with
ftpfs: Disconnecting from ftp.gnu.org
or Can not change directory dialog box.

Log is short including here:
220 GNU FTP server ready.
MC -- remote_is_amiga =  0
USER anonymous
230-Due to U.S. Export Regulations, all cryptographic software on this
230-site is subject to the following legal notice:
230-
230-    This site includes publicly available encryption source code
230-    which, together with object code resulting from the compiling of
230-    publicly available source code, may be exported from the United
230-    States under License Exception "TSU" pursuant to 15 C.F.R. Section
230-    740.13(e).
230-
230-This legal notice applies to cryptographic software only. Please see
230-the Bureau of Industry and Security (www.bxa.doc.gov) for more
230-information about current U.S. regulations.
230 Login successful.
PWD
257 "/"
EPSV
229 Entering Extended Passive Mode (|||53298|)
EPRT |1|192.168.4.22|35000|
200 EPRT command successful. Consider using EPSV.
TYPE A
200 Switching to ASCII mode.
LIST -la /.
425 Failed to establish connection.
CWD /
250 Directory successfully changed.
EPRT |1|192.168.4.22|39825|
200 EPRT command successful. Consider using EPSV.
LIST
425 Failed to establish connection.
EPRT |1|192.168.4.22|38388|
200 EPRT command successful. Consider using EPSV.
LIST
425 Failed to establish connection.
QUIT
Comment 8 artem 2006-11-08 04:23:01 EST
Have the same problem but not only with passive mode (i use ipv4): log is

220 (vsFTPd 1.2.2)
MC -- remote_is_amiga =  0
USER anonymous
331 Please specify the password.
PASS <Password not logged>
230 Login successful.
PWD
257 "/"
CWD /
250 Directory successfully changed.
EPSV
229 Entering Extended Passive Mode (|||5490|)
EPRT |1|192.168.11.8|37930|
500 Bad EPRT protocol.
PORT 192,168,11,8,42,148
500 Illegal PORT command.
EPRT |1|192.168.11.8|59117|
500 Bad EPRT protocol.
PORT 192,168,11,8,237,230
500 Illegal PORT command.
EPRT |1|192.168.11.8|35712|
500 Bad EPRT protocol.
PORT 192,168,11,8,128,139
500 Illegal PORT command.
QUIT
Comment 9 Jindrich Novy 2006-11-20 09:23:19 EST
This should be fixed since mc-4.6.1a-35 which is now built in rawhide. Please
let me know whether the passive ftp mode now works for you. I'll release FC5/FC6
updates as soon as I see possitive feedback.
Comment 10 Fedora Update System 2006-11-22 11:25:52 EST
mc-4.6.1a-35.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 11 Adam Pribyl 2006-11-22 13:29:07 EST
Confirming that ftpfs is working for me now.
Comment 12 artem 2006-11-23 04:25:11 EST
Yeah, it works.

Note You need to log in before you can comment on or make changes to this bug.