Bug 213213 - [CJKI][fix available] html paste from konqueror loaded in wrong encoding
Summary: [CJKI][fix available] html paste from konqueror loaded in wrong encoding
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org   
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Caolan McNamara
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-31 10:05 UTC by Xiaohong Wang
Modified: 2008-05-21 17:24 UTC (History)
3 users (show)

Fixed In Version: RHBA-2008-0463
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 17:24:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (310.95 KB, image/png)
2006-10-31 10:07 UTC, Xiaohong Wang
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0463 normal SHIPPED_LIVE OpenOffice.org bug fix update 2008-05-20 20:05:15 UTC
OpenOffice.org 76649 None None None Never

Description Xiaohong Wang 2006-10-31 10:05:45 UTC
Description of problem:


Version-Release number of selected component (if applicable):
RHEL5-Client-20061027.0
kdebase-3.5.4-12.fc6
openoffice-2.0.4-5.4.1
gedit-2.16.0-4.el5
m17n-db-gujarati-1.3.3-33.el5


How reproducible:


Steps to Reproduce:
1. launch konqueror and open <http://gu.wikipedia.org/wiki/મુખપૃષ્ઠ>
2. select some gu_IN text and use ctrl+c to copy the content
3. open oowriter and use ctrl+v to paste the content to oowriter
  
Actual results:
text display abnormally

Expected results:


Additional info:
past the same content to gedit, it displays normally
copy gu_IN text from firefox and past to oowriter, it displays normally

Comment 1 Xiaohong Wang 2006-10-31 10:07:10 UTC
Created attachment 139828 [details]
screenshot

Comment 2 Nicole Dai 2007-01-15 05:03:04 UTC
The problem was still found in CJKI locales on RHEL5-Client-20070105.0 Snap #6
(libicu-3.6-5.8).

It can be reproduced by the following steps:
1.Log in system with any CJKI locale, such as zh_CN locale.
2.Open oowriter.
3.Run "konqueror
/usr/share/doc/redhat-release-notes-4.92Client/RELEASE-NOTES-x86-zh_CN.html".
4.Copy some Chinese text to oowriter.

Comment 3 RHEL Product and Program Management 2007-03-21 23:44:06 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Caolan McNamara 2007-04-24 07:36:41 UTC
well this is either konqueror or openoffice.org and not icu, the rendering is
fine. The problem is with the encoding of the data on paste. e.g. use paste
special and text instead of html.

Comment 5 Caolan McNamara 2007-04-24 09:57:18 UTC
I only got this today, so I'd like to punt it to 5.2.0 not 5.1.0 to give some
time to upstream to consider my patch

Comment 6 Caolan McNamara 2007-04-24 10:00:30 UTC
acking for 5.2.0. 

FWIW currently 
a) the paste is wrong for html from konqueror in writer and in draw, but should
be ok in calc
b) paste special and "as text" shuold be ok in all apps
c) paste of html from firefox should be ok in all apps

so it only affects from konqueror to writer and draw

Comment 8 RHEL Product and Program Management 2007-10-16 04:09:14 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 9 Caolan McNamara 2007-10-24 16:29:23 UTC
building, will be openoffice_org-2.3.0-6.1.el5

Comment 10 Caolan McNamara 2007-10-26 08:54:39 UTC
No 5.2 errata target available yet to file errata, builds available as
openoffice_org-2.3.0-6.2.el5

Comment 12 David Tonhofer 2008-03-19 21:37:13 UTC
This problem is alive and well on Fedora 8, UTF-8 encoded data on the clipboard
is interpreted as ISO-8859-1 on paste. Packages are:

openoffice.org-core-2.3.0-6.11.fc8
openoffice.org-writer-2.3.0-6.11.fc8
kdebase-3.5.9-3.fc8 (for konqueror)

As said above, copying from konqueror and pasting to openoffice-writer using
"paste special" is a good workaround. 



Comment 15 errata-xmlrpc 2008-05-21 17:24:22 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0463.html



Note You need to log in before you can comment on or make changes to this bug.