Bug 213216 - openssl-ibmca can't be loaded despite being present
openssl-ibmca can't be loaded despite being present
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openssl (Show other bugs)
5.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On: 215735
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 05:48 EST by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 16:13:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
openssl-0.9.8b-aliasing-bug.patch (807 bytes, patch)
2006-10-31 05:48 EST, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2006-10-31 05:48:29 EST
openssl-ibmca-1.0.0.rc2-1.el5.1

Setting up the ibmca plugin in the ssl.cnf, you'd get:
# openssl engine
Error configuring OpenSSL
12217:error:25066067:DSO support routines:DLFCN_LOAD:could not load the shared
library:dso_dlfcn.c:162:filename(/usr/local/ssl/lib/engines/libibmca.so):
/usr/local/ssl/lib/engines/libibmca.so: cannot open shared object file: No such
file or directory
12217:error:25070067:DSO support routines:DSO_load:could not load the shared
library:dso_lib.c:244:
12217:error:260B6084:engine routines:DYNAMIC_LOAD:dso not found:eng_dyn.c:450:
12217:error:0E07606D:configuration file routines:MODULE_RUN:module
initialization error:conf_mod.c:234:module=engines, value=engine_section, retcode=-1

The problem is caused by a miscompilation in the .so loader. Patch from Andreas
Krebbel attached
Comment 1 Bastien Nocera 2006-10-31 05:48:30 EST
Created attachment 139830 [details]
openssl-0.9.8b-aliasing-bug.patch
Comment 2 RHEL Product and Program Management 2006-10-31 06:00:38 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Note You need to log in before you can comment on or make changes to this bug.