Bug 213218 - mkqdisk -f <label> does not work
mkqdisk -f <label> does not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 05:56 EST by Riaan van Niekerk
Modified: 2009-04-16 16:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0149
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 16:47:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes behavior (492 bytes, patch)
2006-10-31 09:57 EST, Lon Hohberger
no flags Details | Diff
Above patch missed something. (781 bytes, patch)
2006-10-31 10:04 EST, Lon Hohberger
no flags Details | Diff
i686 test package (56.17 KB, application/octet-stream)
2006-11-01 15:59 EST, Lon Hohberger
no flags Details
source rpm (69.30 KB, application/octet-stream)
2006-11-01 16:00 EST, Lon Hohberger
no flags Details

  None (edit)
Description Riaan van Niekerk 2006-10-31 05:56:32 EST
Description of problem:

the "-f <label>" option does not work

Version-Release number of selected component (if applicable):
mkqdisk v0.5, cman-1.0.11-0

How reproducible:

every time

Steps to Reproduce:
1. (on an EMC array running PowerPath) mkqdisk -c /dev/emcpowera1 -l quorum_disk_1
2. mkqdisk -f quorum_disk_1
  
Actual results:

Only qdisk version number is displayed

Expected results:
(as per the mkqdisk man page):
Find the cluster quorum disk with the given label and display information about it..
Comment 1 Lon Hohberger 2006-10-31 09:53:20 EST
Definitely a bug.  -f should work.  (-L does).
Comment 2 Lon Hohberger 2006-10-31 09:57:24 EST
Created attachment 139856 [details]
Fixes behavior
Comment 3 Lon Hohberger 2006-10-31 10:04:39 EST
Created attachment 139858 [details]
Above patch missed something.

[root@red qdisk]# ./mkqdisk -L
mkqdisk v0.5.1
/dev/sdb1:
	Magic:	 eb7a62c2
	Label:	 foo
	Created: Thu Jun 22 17:47:35 2006
	Host:	 red.lab.boston.redhat.com

[root@red qdisk]# ./mkqdisk -f bar
mkqdisk v0.5.1
[root@red qdisk]# ./mkqdisk -f foo
mkqdisk v0.5.1
/dev/sdb1:
	Magic:	 eb7a62c2
	Label:	 foo
	Created: Thu Jun 22 17:47:35 2006
	Host:	 red.lab.boston.redhat.com
Comment 4 Lon Hohberger 2006-10-31 10:06:07 EST
Do you want me to build test RPMs, or would you like to build qdisk?
Comment 5 Riaan van Niekerk 2006-11-01 05:35:03 EST
test RPM, please
Comment 6 Lon Hohberger 2006-11-01 15:59:56 EST
Created attachment 140035 [details]
i686 test package
Comment 7 Lon Hohberger 2006-11-01 16:00:37 EST
Created attachment 140036 [details]
source rpm
Comment 8 Riaan van Niekerk 2006-11-01 16:16:40 EST
the patch works for me too:

[sargas:~]# mkqdisk -f quorum_disk_1
mkqdisk v0.5.1
/dev/sdc1:
        Magic:   eb7a62c2
        Label:   quorum_disk_1
        Created: Mon Oct 30 16:15:57 2006
        Host:    sargas.telkomsa.net

[sargas:~]# mkqdisk -f quorum_disk_2
mkqdisk v0.5.1

Note You need to log in before you can comment on or make changes to this bug.