Bug 213244 - automount, hpiod, mcstransd, gpm,yum-updatesd ... gives a selinux messages
automount, hpiod, mcstransd, gpm,yum-updatesd ... gives a selinux messages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 09:03 EST by Jurandy Junior
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: selinux-policy-2.4.5-3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 16:05:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (1.92 MB, text/plain)
2006-10-31 09:03 EST, Jurandy Junior
no flags Details

  None (edit)
Description Jurandy Junior 2006-10-31 09:03:13 EST
Hi,

I upgraded (not reinstall) FC5 to FC6.

I updated kernel.586 (bug:anaconda) to kernel.686.

Kernel Version:
[root@weise ~]# uname -r
2.6.18-1.2798.fc6

I have selinux installed and running in enforcing mode.
[root@weise ~]# rpm -qa | grep selinux
selinux-policy-2.4.1-3.fc6
libselinux-devel-1.30.29-2
libselinux-1.30.29-2
libselinux-python-1.30.29-2

[root@weise jurandy]# cat /var/log/messages > messages.log
Attach as message.log


A lot of programs (ie: automount, hpiod, mcstransd, gpm, yum-updatesd...) give a
selinux messages, see attachment messages.log

More information:
[root@weise ~]# cat .xsession-errors 
Introspect error: An SELinux policy prevents this sender from sending this
message to this recipient (rejected message had interface
"org.freedesktop.DBus.Introspectable" member "Introspect" error name "(unset)"
destination "edu.duke.linux.yum")
Unable to connect to yum-updatesd...


I reported bugs to automount
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=212820), hpiod
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=212821) and mcstrand
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=212822).

Because this messages, automount failed on up, hpiod and mcstransd failed on down.

I tried:

restorecon -F -R -v /

Unfortunately, the error persists.

Could help me to fix this?

Regards,

Jurandy Junior
Comment 1 Jurandy Junior 2006-10-31 09:03:15 EST
Created attachment 139853 [details]
/var/log/messages
Comment 2 Daniel Walsh 2006-11-09 14:57:29 EST
Could you clear your log file, then upgrade to the latest policy and then report
errors.  Most of the errors you have reported are fixed in the current policy.

The policy update may have failed because of labeling problems.
Comment 3 Daniel Walsh 2006-11-28 16:05:52 EST
Fixed in selinux-policy-2.4.5-3.fc6

Note You need to log in before you can comment on or make changes to this bug.