Bug 213304 - GKrellM/libsensors combo borked on VIA 686
GKrellM/libsensors combo borked on VIA 686
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gkrellm (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 13:44 EST by Ian Pilcher
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 20:25:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Pilcher 2006-10-31 13:44:54 EST
Description of problem:

The patch that adds libsensors support to 2.2.9 uses the name of a sensor to
determine its type.  Specifically, it expects all voltage sensors to have
names like in0, in1, etc.

Unfortunately, for VIA 686 chips (and possible others) libsensors
"automagically" returns a human-readable name, which is supposed to be
compatible with the 2.4 kernel names.  When GKrellM enumerates the sensors
on my system, it gets 2.0V, 2.5V, 3.3V, 5.0V, and 12V -- rather than in0,
in1, in2, in3, in4.  Needless to say, GKrellM has no idea what to make of
these sensor names.

I've posted about this on the lm_sensors mailing list.  The response that I
received indicated that lm_sensors 2.11.0 will provide a new API to access
the "normalized" names.  The behavior of the existing API will not be changed.

Fortunately, GKrellM 2.2.10 has built-in libsensors support (no patch needed).
Moreover, it provides a --without-libsensors command line switch which makes
it revert to reading the sysfs files directly, which will work around the
problem.

Please, can we have GKrellM 2.2.10 in FE6?  :-)


Version-Release number of selected component (if applicable):

gkrellm-2.2.9-10.fc6


How reproducible:

100%


Steps to Reproduce:

See above.

  
Actual results:

See above.


Expected results:

See above.


Additional info:
Comment 1 Hans de Goede 2006-11-07 05:35:42 EST
Thanks for reporting this and sorry for the long silence I've been rather busy.
2.2.10 is currently in development / rawhide, you can grab it from there.

The --without-libsensors cmdline options is nice, but not really a solution,
I'll write a patch for the libsensors support to also recognise the odd-named
voltages on the VIA 686. I'll get back to you via this bug once this patch is in
development so that you can test it before I push 2.2.10 + this patch to FC-6.
Comment 2 Ian Pilcher 2006-11-07 20:25:11 EST
No problem.  Been using 2.2.10 since I saw your note on fedora-devel.  Working
fine with --without-libsensors.

I wouldn't bother hacking gkrellm to recognize the weird sensor names that
libsensors is reporting; that way lies madness.  I'd wait until the lm_sensors
folks create their new API and use that.
Comment 3 Hans de Goede 2006-11-08 03:07:20 EST
(In reply to comment #2)
> No problem.  Been using 2.2.10 since I saw your note on fedora-devel.  Working
> fine with --without-libsensors.
> 
Good.

> I wouldn't bother hacking gkrellm to recognize the weird sensor names that
> libsensors is reporting; that way lies madness.  I'd wait until the lm_sensors
> folks create their new API and use that.

I believe that the VIA 686 voltages are the only exception, but I agree if more
exceptions pop up then we should not support those all, as that way indeed lies
madness.
Comment 4 Hans de Goede 2006-11-08 13:36:42 EST
2.2.10-2 should show up on a mirror near you soon, can you please test that to
see if it works without using --without-libsensors (so --with-libsensors
effectivly).

Thanks!

Note You need to log in before you can comment on or make changes to this bug.