Bug 213333 - Frysk menu selections misbehaving
Frysk menu selections misbehaving
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: frysk (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Andrew Cagney
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 16:14 EST by Daniel Qarras
Modified: 2008-07-14 17:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-14 17:48:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2006-10-31 16:14:31 EST
Description of problem:
When selecting View->* Window and closing the window from its Close button, the
checkbox remains checked. When unchecking the box, a new window appears!

Version-Release number of selected component (if applicable):
frysk-0.0.1.2006.10.30.rh1-1.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Start a Frysk session
2. Select View->Memory Window, see Memory Window opening
3. Select Close from Memory Window
4. Deselect View->Memory Window, see Memory Window opening again

  
Actual results:
Menu misbehaving.

Expected results:
Menu behaving.

Additional info:
.
Comment 1 Daniel Qarras 2007-10-12 16:46:56 EDT
The problem is now with F8T3 that when I try to open View->Memory Window I see
an exception:

java.util.NoSuchElementException
   at java.util.LinkedList$LinkedListItr.next(libgcj.so.8rh)
   at frysk.gui.memory.MemoryWindow.refreshList(frysk)
   at frysk.gui.memory.MemoryWindow.recalculate(frysk)
   at frysk.gui.memory.MemoryWindow.setTask(frysk)
   at frysk.gui.memory.MemoryWindow.finishMemWin(frysk)
   at frysk.gui.memory.MemoryWindowFactory.createMemoryWindow(frysk)
   at frysk.gui.srcwin.SourceWindow.toggleMemoryWindow(frysk)
   at frysk.gui.srcwin.SourceWindow.access$56(frysk)
   at frysk.gui.srcwin.SourceWindow$34.actionEvent(frysk)
   at org.gnu.gtk.Action.fireActionEvent(libgtkjava-2.8.so)
   at org.gnu.gtk.Action.handleActivate(libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.gtk_main(libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.main(libgtkjava-2.8.so)
   at frysk.gui.Gui.gui(frysk)
   at frysk.bindir.frysk.main(frysk)
Comment 2 Daniel Qarras 2008-03-16 07:21:23 EDT
I wanted to test this with latest release but things are just getting worse:

root@localhost:~# rm -rf ~/.frysk
root@localhost:~# rpm -q frysk
frysk-0.0.1.2008.02.29.rh1-1.fc8
root@localhost:~# frysk         
Exception in thread "main" java.lang.NullPointerException
   at frysk.gui.Gui.setupCoreLogging(frysk)
   at frysk.gui.Gui.gui(frysk)
   at frysk.bindir.frysk.main(frysk)
Comment 3 Andrew Cagney 2008-03-17 09:15:52 EDT
This will be fixed in the next update (it is already fixed upstream)
Comment 4 Daniel Qarras 2008-04-17 12:04:21 EDT
Please don't shoot the messenger but just tried frysk-0.2.1-0.fc8 with Fedora 8
and after opening a Debugging Session and selection View->Memory Window I see again:

root@localhost:~# rm -rf .frysk/
root@localhost:~# frysk
java.util.NoSuchElementException
   at java.util.LinkedList$LinkedListItr.next(libgcj.so.8rh)
   at frysk.gui.memory.MemoryWindow.refreshList(frysk)
   at frysk.gui.memory.MemoryWindow.recalculate(frysk)
   at frysk.gui.memory.MemoryWindow.setTask(frysk)
   at frysk.gui.memory.MemoryWindow.finishMemWin(frysk)
   at frysk.gui.memory.MemoryWindowFactory.createMemoryWindow(frysk)
   at frysk.gui.srcwin.SourceWindow.toggleMemoryWindow(frysk)
   at frysk.gui.srcwin.SourceWindow.access$56(frysk)
   at frysk.gui.srcwin.SourceWindow$34.actionEvent(frysk)
   at org.gnu.gtk.Action.fireActionEvent(libgtkjava-2.8.so)
   at org.gnu.gtk.Action.handleActivate(libgtkjava-2.8.so)
java.util.NoSuchElementException
   at java.util.LinkedList$LinkedListItr.next(libgcj.so.8rh)
   at frysk.gui.memory.MemoryWindow.refreshList(frysk)
   at frysk.gui.memory.MemoryWindow.load(frysk)
   at frysk.gui.memory.MemoryWindow.finishMemWin(frysk)
   at frysk.gui.memory.MemoryWindow$LockObserver.update(frysk)
   at java.util.Observable.notifyObservers(libgcj.so.8rh)
   at frysk.stepping.SteppingEngine$SteppingObserver.notifyNotBlocked(frysk)
   at frysk.stepping.SteppingEngine.continueExecution(frysk)
   at frysk.stepping.SteppingEngine.removeObserver(frysk)
   at frysk.gui.srcwin.SourceWindow$7.actionEvent(frysk)
   at org.gnu.gtk.Action.fireActionEvent(libgtkjava-2.8.so)
   at org.gnu.gtk.Action.handleActivate(libgtkjava-2.8.so)

It's a pity that while apparently a great deal of work was invested to engine
the GUI is still so unpolished that it doesn't encourage to experiment at all.

Thanks.
Comment 5 Daniel Qarras 2008-06-12 12:04:05 EDT
Still broken on latest update. Now tested with versions:

frysk-0.4-0.fc9.i386
frysk-devel-0.4-0.fc9.i386
frysk-gnome-0.4-0.fc9.i386
Comment 6 Daniel Qarras 2008-07-14 17:48:34 EDT
Well since Frysk development is in turmoil I guess it makes no sense to keep
bugs like this open. I'll close this one.

Note You need to log in before you can comment on or make changes to this bug.