Bug 213336 - add images for keyboard layouts
add images for keyboard layouts
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Lubomir Kundrak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 16:28 EST by Armijn Hemel
Modified: 2008-04-11 16:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 16:36:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Armijn Hemel 2006-10-31 16:28:17 EST
Description of problem:

Right now (FC6 release) when chosing the keyboard layout, the keyboard that fits
the locale is chosen. This is not always the wisest choice. For example, the
Dutch keyboard layout is not used that much, most systems sold here use US
keyboard layout. Since many users don't know the difference it might be a good
idea to show a picture of a keyboard, or some representation of a keyboard,
which depicts the keyboard layout for that language, or highlights keys in the
picture with which you can recognize a certain keyboard.

This is just a suggestion, feel free to implement, adapt or ignore :)

Version-Release number of selected component (if applicable):


How reproducible:
n/a

Steps to Reproduce:
1. n/a
2.
3.
  
Actual results:

n/a

Expected results:

n/a

Additional info:
Comment 1 Jeremy Katz 2006-10-31 17:56:17 EST
The problem with doing something like this traditionally has been the lack of
available images
Comment 2 Tim Mayberry 2006-10-31 21:00:44 EST
gnome-keyboard-preferences can display many different keyboard layouts. I think
it does it using a library called libkbdraw although I'm not too sure about
that. Perhaps using that, or generating static images from that is an option?
Comment 3 Chris Lumens 2007-02-22 16:00:37 EST
If system-config-keyboard supports this, anaconda will be able to make use of it
fairly easily.  We just wrap the screen it provides.
Comment 4 Red Hat Bugzilla 2007-08-21 01:28:53 EDT
User pnasrat@redhat.com's account has been closed
Comment 5 Lubomir Kundrak 2008-04-11 16:36:06 EDT
gnome-keyboard-preferences should be used instead.

Note You need to log in before you can comment on or make changes to this bug.