This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 213354 - Crash when set device statics routes for any device
Crash when set device statics routes for any device
Status: CLOSED DUPLICATE of bug 211980
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 18:34 EST by Otto Rey
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 05:53:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Otto Rey 2006-10-31 18:34:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
Crash when try to set static routes to netowrk devices

Version-Release number of selected component (if applicable):
1.3.95-1

How reproducible:
Always


Steps to Reproduce:
1. Run system-config-network
2. Modify a device
3. Go to route Tab
4. Click Add
5. Put any values and click Ok

Actual Results:
Crash generating log

Expected Results:
Add the route to static routes list

Additional info:
Component: system-config-network
Version: 1.3.95
Summary: TB94e1a8fa sharedtcpip.py:176:route_update:TypeError: sequence item not a string or unicode object

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/sharedtcpip.py", line 284, in on_routeAddButton_clicked
    route_update(xml, device)
  File "/usr/share/system-config-network/netconfpkg/gui/sharedtcpip.py", line 176, in route_update
    clist.append([route.Address, route.Netmask, route.Gateway])
TypeError: sequence item not a string or unicode object

Local variables in innermost frame:
device: Device.AutoDNS=true
Device.Hostname=desktop
Device.HardwareAddress=00:0E:A6:5C:93:C7
Device.Type=Ethernet
Device.IPv6Init=false
Device.StaticRoutes.1.Gateway=['192.168.1.1']
Device.StaticRoutes.1.Netmask=['255.255.255.0']
Device.StaticRoutes.1.Address=['192.168.100.0']
Device.Netmask=
Device.BootProto=dhcp
Device.Device=eth0
Device.OnBoot=false
Device.IP=
Device.OnParent=false
Device.DeviceId=eth0
Device.AllowUser=false
Device.Gateway=

xml: <glade.XML object (PyGladeXML) at 0xb7a21dec>
route: Route.Gateway=['192.168.1.1']
Route.Netmask=['255.255.255.0']
Route.Address=['192.168.100.0']

clist: <gtk.CList object (GtkCList) at 0xb7a1a11c>
Comment 1 Harald Hoyer 2006-11-02 05:53:33 EST

*** This bug has been marked as a duplicate of 211980 ***

Note You need to log in before you can comment on or make changes to this bug.